Bug 56688 - Emacs leaves console in bad state after exit (not under X)
Summary: Emacs leaves console in bad state after exit (not under X)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-25 00:06 UTC by Leigh L. Klotz, Jr.
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-25 00:06:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leigh L. Klotz, Jr. 2001-11-25 00:06:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
This is related to the NOTABUG 55386 but since I'm not that bug's owner I
couldn't re-open it.  I have included steps to reproduce the bug here.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Linux 7.2 with current updates, including emacs and
emacs-nox.  Set defualt runlevel to 3 -- do not start X.
2. Log in to console.  Do not start X.
3. Type "emacs".
4. Type "control-x control-c"
5. Note that the terminal now no longer echoes.  
6. Type "reset" at the shell to fix things.
7. Start "emacs" again.
8. Suspened emacs by typing "control-x control-z"
9. Observe that the shell is fine now.


Actual Results:  Shell doesn't echo and requires 'reset'

Expected Results:  Shell does echo and does not require 'reset'


Additional info:

I have seen this bug on three different systems.  "->" indicates an
upgrade, all with installations upgraded to current patch levels.

#1 7.0->7.1->7.2 Pentium II 450
#2 7.0->7.1->7.2 K6-II 450
#3 6.2->7.0->7.1->7.2 Pentium II 200

Comment 1 Trond Eivind Glomsrxd 2001-11-26 16:44:51 UTC
I can't reproduce this on a vanilla+updates RHL 7.2 system with this procedure.
I don't experience any problems at all...


Note You need to log in before you can comment on or make changes to this bug.