Bug 566887 - [abrt] "package-cleanup -C --orphans" crash
[abrt] "package-cleanup -C --orphans" crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:73165f78
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-20 02:47 EST by Matt McCutchen
Modified: 2014-01-21 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version: yum-utils-1.1.27-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 13:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.66 KB, text/plain)
2010-02-20 02:47 EST, Matt McCutchen
no flags Details

  None (edit)
Description Matt McCutchen 2010-02-20 02:47:46 EST
abrt 1.0.6 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/package-cleanup -C --orphans
component: yum-utils
executable: /usr/bin/package-cleanup
kernel: 2.6.31.12-174.2.19.fc12.x86_64
package: yum-utils-1.1.25-1.fc12
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Delete any per-user yum cache at /var/tmp/yum-$USER-* .
2. package-cleanup -C --orphans
Comment 1 Matt McCutchen 2010-02-20 02:47:47 EST
Created attachment 395223 [details]
File: backtrace
Comment 2 Tim Lauridsen 2010-05-02 04:47:43 EDT
I have added some exception catching in this commit

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=c5aa6845f4b0cf6ffbc0e725b9cff108e1dd3d58

[tim@hoth yum-utils]$ rm -rf /var/tmp/yum-tim-uQtoiY/
[tim@hoth yum-utils]$ ./package-cleanup.py -C --orphans
Loaded plugins: presto, refresh-packagekit, remove-with-leaves
Error: Cannot access repository dir /var/tmp/yum-tim-bPtiE_/i386/13/adobe-linux-i386

So now it dont blowup but give you and error

The error is ok, because you cant use the cache if there is no cache, but maybe it should be a little better message.
Comment 3 Matt McCutchen 2010-05-05 23:28:56 EDT
(In reply to comment #2)
> The error is ok, because you cant use the cache if there is no cache

No, it should use the system-wide cache like "yum -C" does.
Comment 4 Fedora Update System 2010-06-06 09:45:12 EDT
yum-utils-1.1.27-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yum-utils-1.1.27-1.fc13
Comment 5 Fedora Update System 2010-06-08 15:35:39 EDT
yum-utils-1.1.27-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yum-utils-1.1.27-2.fc13
Comment 6 Fedora Update System 2010-06-14 13:20:34 EDT
yum-utils-1.1.27-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Matt McCutchen 2010-07-17 01:00:21 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > The error is ok, because you cant use the cache if there is no cache
> 
> No, it should use the system-wide cache like "yum -C" does.    

This is now bug 615559.

Note You need to log in before you can comment on or make changes to this bug.