Bug 566909 - RFE: please change isdn4k-utils to use capi20.new
Summary: RFE: please change isdn4k-utils to use capi20.new
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: isdn4k-utils
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 591900 592487
TreeView+ depends on / blocked
 
Reported: 2010-02-20 11:25 UTC by Louis Lagendijk
Modified: 2010-06-07 22:33 UTC (History)
1 user (show)

Fixed In Version: isdn4k-utils-3.2-71.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-07 22:09:10 UTC


Attachments (Terms of Use)
This spec file needs some change to the Makefile, to be cleaned up (28.22 KB, application/octet-stream)
2010-02-20 11:29 UTC, Louis Lagendijk
no flags Details
tar file with updated spec file and some aux. files (9.23 KB, application/x-gzip)
2010-04-19 22:33 UTC, Louis Lagendijk
no flags Details
Updated capi20.conf (703 bytes, application/octet-stream)
2010-05-07 21:05 UTC, Louis Lagendijk
no flags Details
Patch to the spec file, own libdir/capi, additional patch21 for plugin detection (2.82 KB, patch)
2010-05-07 21:06 UTC, Louis Lagendijk
no flags Details | Diff
Patch to capi20.new, so it detects the .so.x libs, rather than the .so (1.15 KB, patch)
2010-05-07 21:08 UTC, Louis Lagendijk
no flags Details | Diff

Description Louis Lagendijk 2010-02-20 11:25:09 UTC
Description of problem:
I am working on packaging ffgtk, a solution for controlling the FRITZ!Box or compatible router with Linux. It offers a rich feature list, including caller monitor and fax support. This requires a remote-capi. Capi20.new is now avaialable in the upstream isdn4k-utils.  This version offers support for the traditional local capi as well as remote capi (based on plugins). According to https://bugs.launchpad.net/ubuntu/+source/isdnutils/+bug/420918 suse ships the new capi already for some time. The capi4linux rpm for Suse indeed includes the plugins. Could we please update as well?

If that helps, I can work on the required changes (I already have spec file that works, but should be cleaned up a bit).

Version-Release number of selected component (if applicable):
Current CVS of isdn4k-utils

How reproducible:
NA

Steps to Reproduce:
NA
  
Actual results:


Expected results:


Additional info:

Comment 1 Louis Lagendijk 2010-02-20 11:29:37 UTC
Created attachment 395243 [details]
This spec file needs some change to the Makefile, to be cleaned up

Comment 2 Louis Lagendijk 2010-04-19 22:33:02 UTC
Created attachment 407693 [details]
tar file with updated spec file and some aux. files

Comment 3 Louis Lagendijk 2010-04-19 22:35:20 UTC
I have added a more complete spec file, based on the -68 version of isdn4k-utils. Will it be feasible to include these changes? If not, I can package the capi separately and set isdn4k-utils as conflicting, if you prefer so

Comment 4 Ngo Than 2010-05-04 12:45:38 UTC
isdn4k-utils-3_2-70_fc14 is built in rawhide. It now supports the capi20.new.

Comment 5 Louis Lagendijk 2010-05-07 21:03:12 UTC
Hi Ngo
I rebuilt the -70 RPM on my F12 and found a few small issues:
1) plugins are not loaded due to the fact that libcapi20.so.3 only looks for .so plugins. Patch attached
2) I forgot to own %{_libdir}/capi (patch to spec file attached)
3) a small addition to the template /etc/capi20.conf: added portnumber

Comment 6 Louis Lagendijk 2010-05-07 21:05:05 UTC
Created attachment 412445 [details]
Updated capi20.conf

Comment 7 Louis Lagendijk 2010-05-07 21:06:57 UTC
Created attachment 412446 [details]
Patch to the spec file, own libdir/capi, additional patch21 for plugin detection

Comment 8 Louis Lagendijk 2010-05-07 21:08:06 UTC
Created attachment 412448 [details]
Patch to capi20.new, so it detects the .so.x libs, rather than the .so

Comment 9 Ngo Than 2010-05-14 16:06:41 UTC
it's fixed in isdn4k-utils-3_2-71_fc14. Louis, could you please test it?
thanks

Comment 10 Louis Lagendijk 2010-05-14 19:11:23 UTC
Got the -71 from koji and rebuilt it for my F12 and tested the result. Works now as expected. thanks for the quick reponse!

Comment 11 Fedora Update System 2010-05-28 12:26:00 UTC
isdn4k-utils-3.2-71.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/isdn4k-utils-3.2-71.fc13

Comment 12 Fedora Update System 2010-05-28 12:27:10 UTC
isdn4k-utils-3.2-71.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/isdn4k-utils-3.2-71.fc12

Comment 13 Fedora Update System 2010-05-31 18:17:53 UTC
isdn4k-utils-3.2-71.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update isdn4k-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/isdn4k-utils-3.2-71.fc12

Comment 14 Fedora Update System 2010-05-31 18:27:21 UTC
isdn4k-utils-3.2-71.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update isdn4k-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/isdn4k-utils-3.2-71.fc13

Comment 15 Fedora Update System 2010-06-07 22:09:05 UTC
isdn4k-utils-3.2-71.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-06-07 22:33:45 UTC
isdn4k-utils-3.2-71.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.