Bug 56693 - New Dell Dimension 4300 w/ A02 BIOS screen not visible with syslinux or lilo
New Dell Dimension 4300 w/ A02 BIOS screen not visible with syslinux or lilo
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-25 00:47 EST by Steve Prior
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 14:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Prior 2001-11-25 00:47:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
It seems that a new "feechur" in very recent Dell Dimension systems is that they show NO screen output when booted until the screen mode
is reset or put into graphics mode.  I suspect this is due to a M$ decree to keep the screen clear until a graphical boot logo shows up.  The syslinux folks 
have a patch that fixes the problem by resetting the screen on boot.  Graphical lilo works fine, but text based lilo currently does not.
This is a problem for the Red Hat (all versions) bootable CD because it is text mode lilo, so the user currrently sees no screen output until
the installer switches to graphics mode.  Fortunatly the fix is extremely minor.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Buy a new Dell Dimension 4300 (and soon I suspect other brand machines)
2. Boot the Red Hat install CD
3. observe NOTHING on the screen until screen mode switch.
	

Actual Results:  blank screen

Expected Results:  text output on screen

Additional info:
Comment 1 Brent Fox 2001-11-29 16:43:09 EST
Interesting.  We don't have any recent Dimension equipment, so I can't reproduce
this problem.  Is there a setting in the BIOS that you can turn off?

Actually, the text mode cd boot screen is syslinux, not lilo.
Comment 2 Steve Prior 2001-11-30 07:57:39 EST
Sorry I can't buy you a new Dell Dimension 4300 to try it out...

No setting in the BIOS, that's the first thing I checked.  I have a version of syslinux-1.64-pre6 which the
author of syslinux has patched to solve this problem, though the author isn't sure yet about installing
this patch mainstream  - I think he's just being careful (which is good), but it should be OK.  Also,
LILO 21.1-1 alpha3 has this problem fixed in text mode (it wasn't an issue with graphical lilo since
that does the required mode change).

If my suspicion is true that this feature is a new mandate from M$, then it is unfortunate that the RH 7.2
CD's have a syslinux which doesn't work with the brand new machines - it is always bad news when 
a new user experience has problems.  Personally I'd like to see the BIOS fixed, but that might be a big
hill to climb.

Thanks
Steve
Comment 3 Brent Fox 2001-12-03 23:44:39 EST
Fascinating.  What an odd thing to put in a bios.  msw, do you know anyone at
Dell that could provide some insight into this?
Comment 4 Steve Prior 2001-12-04 07:20:23 EST
Unfortunatly not, I've been trying to go through Dell support, but so far they have been totally clueless.
Personally I think that this behavio should be switchable in the BIOS options.

Steve
Comment 5 Brent Fox 2001-12-18 11:54:38 EST
Without having the hardware to test on, I don't know what I can do about this...
Comment 6 Brent Fox 2002-01-22 00:56:57 EST
I've talked to a Dell engineer that suggested that you try a different monitor
on the system in question.  I'd be surprised if that changes anything, but it's
worth a shot.  Any luck?
Comment 7 Brent Fox 2002-01-31 12:38:25 EST
sprior, any more info here?
Comment 8 Steve Prior 2002-01-31 21:51:16 EST
Yeah, the info is that the Dell guy doesn't have a CLUE!  It's not the monitor, that's a total joke.  The sympton has
been totally diagnosed to software - even a DOS boot floppy doesn't show anything until it encounters a CLS
command.  The author of lilo has diagnosed this down to the register which is set wrong.

Thanks
Steve
Comment 9 Brent Fox 2002-02-01 11:57:58 EST
Ok, I've sent another email to my contact at Dell requesting some loaner
hardware.  Hopefully we can get some in order to reproduce this problem.  I
don't have much chance to fix the problem without hardware.  :(
Comment 10 Pete Woytovech 2002-02-11 11:39:09 EST
Could be a video card problem...

It seems to work fine on mine...(4300, BIOS A02, 1.7 GHz, Rage128 Pro II, Video 
BIOS date 5/29/01)...

I get:

"            Welcome to Red Hat Linux 7.2!

-  To install or upgrade Red Hat in graphical mode, press the <ENTER> key.

...

...                  [F5-Rescue]
boot:
"

What do you get when you fail?

When I boot a win 95 boot diskette, I get:

Starting Windows 95...

What kind of video card do you have on the failing machine?

If you can get the DELL P/N off of the failing card, I can get one of those and 
take a look...
Comment 11 Pete Woytovech 2002-02-12 14:31:56 EST
Customer has a Dell version NVIDIA GeForce2 MX with TVout...just tried one of 
those and it worked fine.  May be a defective video card.  

Working on swapping card out...
Comment 12 Brent Fox 2002-02-13 14:06:03 EST
sprior, do you have another video card you could try?
Comment 13 Brent Fox 2002-02-28 22:37:50 EST
Ok, since sprior doesn't have any new information to add and the Dell engineers
can't reproduce the problem, I'm going to close this bug as 'worksforme'.
Comment 14 Steve Prior 2002-02-28 22:45:03 EST
Dell provided me with a newer revision of the same video card and it appears that it has helped, though I have yet to complete testing to make sure 
the problem is gone.  It is not at all clear if this was a defective card or a bug int he revision of the old card.  I'll advise when I've completed more 
tests.

Thanks
Steve Prior
Comment 15 Brent Fox 2002-03-01 01:37:49 EST
Ok.  It appears that the issue was hardware related.  If further tests reveal
more problems and you think the software is at fault, please reopen this bug
report.  

In any case, feel free to respond to this report with whatever you find, because
I'm curious as to what caused the problem in the first place.

Note You need to log in before you can comment on or make changes to this bug.