Bug 566948 - Input devices don't work
Input devices don't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity urgent
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Triaged
Depends On: 566396
Blocks: F13Alpha/F13AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-02-20 11:09 EST by Clyde E. Kunkel
Modified: 2010-02-25 21:18 EST (History)
15 users (show)

See Also:
Fixed In Version: anaconda-13.30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-25 21:18:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2010-02-20 11:09:31 EST
Description of problem:
no keyboard after anaconda initial screen (not test media screen)

Version-Release number of selected component (if applicable):
13.28

How reproducible:
every time

Steps to Reproduce:
1. boot Fedora-13-Alpha-x86_64-DVD
2. skip media test
3. welcome screen comes up and no keyboard or mouse control at this point
  
Actual results:
no keyboard or mouse

Expected results:
keyboard and usable mouse

Additional info:
tried every combination of nomodeset and vesa driver, no joy.

$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV630 [Radeon HD 2600 Series]
Comment 1 Richard Ryniker 2010-02-20 15:14:39 EST
Same result using Gateway GT5426E machine (AMD Athlon x64 CPU), with NVIDEA GeForce 6158SE nForce 430 graphics controller.
Comment 2 shmuel siegel 2010-02-21 01:03:07 EST
Same result with trying to install f13 alpha rc1.i386 on a dell d620 laptop.
Comment 3 He Rui 2010-02-21 01:06:49 EST
same result in any virt-installs.
Comment 4 He Rui 2010-02-21 04:15:47 EST
Set it as F13 alpha blocker bug according to Alpha Release Requirements: 6. The installer must be able to complete an installation using the text, graphical and VNC installation interfaces.
Comment 5 Chris Lumens 2010-02-21 11:34:13 EST
I think this is because of the new X server input configuration system requiring files that anaconda's image building scripts are not accounting for.
Comment 6 Chris Lumens 2010-02-21 13:52:48 EST
This is what I'm thinking of:

* Tue Feb 16 2010 Peter Hutterer <peter.hutterer@redhat.com> 1.7.99.901-1.2010208
- Update to today's git master (1.8RC1)
- xserver-1.7.4-reset-sli-pointers.patch: drop, upstream
- Enable udev config, drop hal.
- Require system-setup-keyboard (renamed fedora-setup-keyboard) 

We probably need to add back in our patch that drops hal and add /etc/xorg.conf.d/* to scripts/upd-instroot.
Comment 7 Jim Haynes 2010-02-21 22:02:37 EST
Same here.  Machine is a HP d530, keyboard is a USB keyboard,
Mouse is a USB mouse with adapter to plug into the PS/2 mouse
socket.
Comment 8 Adam Williamson 2010-02-22 11:15:45 EST
Yes, this is likely because of the migration from hal to udev for input device configuration in X. Why does anaconda need to do special stuff with input configuration? Adding Peter Hutterer to CC, he can advise on the transition.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Ales Kozumplik 2010-02-22 12:00:23 EST
Fixed by 49f12d62f5d9c5cf213a983023000be988ffffc1, will be part of anaconda 13.29.
Comment 10 Ales Kozumplik 2010-02-22 12:02:32 EST
Oh, but there also needs to be a fix in x.org, see #566396.
Comment 11 Peter Hutterer 2010-02-22 22:11:43 EST
(In reply to comment #8)
> Yes, this is likely because of the migration from hal to udev for input device
> configuration in X. Why does anaconda need to do special stuff with input
> configuration? Adding Peter Hutterer to CC, he can advise on the transition.

Thanks for the CC, I missed this one.

before the hal→udev transition we had most of the X server configuration in HAL's fdi files (e.g. the selection of drivers). now this configuration is only in /etc/xorg.conf.d/. Without it the server cannot detect what a device's driver should be, unlike graphics devices we don't have a default driver detection mechanism in the server for input devices.

so we at least need 00-evdev.conf so that the evdev driver is assigned to all input devices. this is essentially the same result as the 10-x11-input.fdi previously used.
Comment 12 He Rui 2010-02-23 05:03:29 EST
This issue still happens on anaconda 13.29 of F13 alpha RC2 (i386).
Comment 13 Kamil Páral 2010-02-23 05:46:55 EST
Still a problem on F13 Alpha RC2 x86_64.
Comment 14 Ales Kozumplik 2010-02-23 07:57:09 EST
Indeed, the problem still persists in RC2, please see bug 566396.
Comment 15 Fedora Update System 2010-02-23 17:07:48 EST
anaconda-13.30-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.30-1.fc13
Comment 16 Clyde E. Kunkel 2010-02-23 18:12:12 EST
vnc install succeeded.  Remote syslog and selinux=0 were also specified.  All worked.
Comment 17 Fedora Update System 2010-02-24 02:59:21 EST
anaconda-13.30-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2803
Comment 18 Clyde E. Kunkel 2010-02-25 00:21:29 EST
works in 13.30.
Comment 19 He Rui 2010-02-25 05:11:00 EST
verified working on anaconda 13.31 i386 platform. X86_64 install exited for segmentation fault before stage1.
Comment 20 Adam Williamson 2010-02-25 21:18:08 EST
Multiple reports that this is fixed, let's close it.

Note You need to log in before you can comment on or make changes to this bug.