This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 56696 - doco gives no clues about how to activate php nor even whether it is DSO or a re-compile job
doco gives no clues about how to activate php nor even whether it is DSO or a...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-25 03:21 EST by Jim Donovan
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 19:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Donovan 2001-11-25 03:21:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (Win98; I)

Description of problem:
when installing rh7.2, one cannot get php working without significant additional effort.
I would have preferred php to be active straight out-of-the box but it doesn't. Then I would
hope that the doco indicated somewhere whether to re-compile apache as discussed at length
on the PHP web site or whether to activate it as a dynamic shared object. Again, the doco is
silent on the matter although the rpm for php-manual (which might not apply to redhat - does it?)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install rh7.2
2.set up a file mytest.php or similar, containing   <? phpinfo() ?>
3. run netscape file:///home/me/mytest.php3  or perhaps try netscape http://127.0.0.1/~my/mytest.php3
4. note that php did not work
	

Actual Results:  the <? whatever ?> is ignored

Expected Results:  the full page of info about your php version should be displayed

Additional info:

as stated above, I suggest it's a matter of documentation but I'm not certain where this
sort of thing is covered in the RH doco I have. I note that the RH web site includes
snippets from the Linux Documentation Project but because RH is customised, one
cannot assume that LDP applies to RH installation.
Comment 1 Jim Donovan 2001-11-28 17:31:31 EST
Update from jimd@wahroonga.com .... it works now. I have discovered that after RH7.0 (which had a separate rpm for
mod-php) RedHat changed it so the php rpm activated itself. However, I still think the doco could show somewhere
that RedHat php runs as a .so and that no recompile is needed, despite the lavish amount of doco published
elsewhere describing how to recompile Apache.
Comment 2 Phil Copeland 2002-01-08 15:32:16 EST
*scratch* ok I'm looking a freshly installed 7.2 box

[root@dhcpd201 public_html]# cat test.php3 
<? phpinfo() ?>

[root@dhcpd201 public_html]# php test.php3 | head -5
X-Powered-By: PHP/4.0.6
Content-type: text/html

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
..etc...

erm,... yes, even shows up ok in netscape.
sorry I can't reproduce this problem on a 7.2 box 

Phil
=--=
Comment 3 Phil Copeland 2002-01-08 15:36:37 EST
Oh,.. one thing I would say
there is a differance in
	lynx file:/root/public_html/test.php3  (will NOT work)
and
	lynx http://localhost/~root/test.php3 (WILL work)

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.