Bug 566969 - F12 installation on Lenovo Thinkpad T410: graphics stays black (no video output)
F12 installation on Lenovo Thinkpad T410: graphics stays black (no video output)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-20 15:04 EST by Werner Fischer
Modified: 2010-04-15 02:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-15 02:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Werner Fischer 2010-02-20 15:04:56 EST
Description of problem:
The video output stays black when I try to install Fedora 12 on my new Thinkpad T410 with nVidia NVS 3100m. I have tried the recent re-spin DVD from http://fedoraunity.org/Members/Southern_Gentleman/fedora-unity-20100202-f12-re-spin-released. The "Welcome to Fedora 12!" screen gets displayed, but when I start the installation the screen turns black. "Install system with basic video driver" does not help, I get a black screen with this option, too. 

Booting the Fedora 12 Live CD also results in a black screen: the "Automatic boot in ... seconds" is displayed (like in this way: http://queasyquagmire.files.wordpress.com/2009/11/01_initial_boot.png), and then the screens turns black.
I'm not sure which nVidia driver is used automatically during installation/boot, so I have chosen the xorg-x11-drv-nv package for this bug.

I have also tried to connect an external monitor. I switched to the external monitor right after powering the T410 on (using Fn+F7). The external monitor shows the first screen ("Welcome to Fedora 12!"), but when I start the installation, it also turns black as the display of the Thinkpad itself before.

How reproducible: just boot a Fedora 12 installation or live CD/DVD on a Lenovo Thinkpad 410 (a model with nVidia graphics)

Additional info: an installtion of Ubuntu 9.10 works. I have started to document this on thinkwiki.org: http://www.thinkwiki.org/wiki/Installing_Ubuntu_9.10_%28Karmic_Koala%29_on_a_ThinkPad_T410
In this forum post another user reports that the installer gets no graphics: http://forum.thinkpads.com/viewtopic.php?f=9&t=84662 The described work around (switching to text mode to tune the brightness level does not work)
Comment 1 Matěj Cepl 2010-02-25 12:41:26 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, system log (/var/log/messages), and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Werner Fischer 2010-02-25 13:21:56 EST
I don't have Fedora running yet on this system, as the installer is failing right at the beginning. I can try to run the live CD (the screen gets dark there too, but according to the noise of the DVD-drive it seems that it is correctly booting). Once I have the live CD running, I'll try to set up a root password, so that I can connect via SSH to the machine (after getting to know the IP address from my DHCP server). Then I'll try to grab the requested outputs.

Thanks very much for your help! I'll keep you updated soon.
Comment 3 Werner Fischer 2010-02-25 14:43:10 EST
I have just tried to boot the live CD but somehow it hangs during boot. I hear the DVD drive keep spinning up and down in the same way - just as if it couldn't read some blocks from the CD. I have also tried another brand of CD-R, but this did not help. On another system these two live CDs both boot without problems.

So unfortunately I see no way to grab the desired infos :-(
As mentioned above, Ubuntu 9.10 works on this T410 Thinkpad.

best regards,
Werner
Comment 4 Ben Skeggs 2010-02-25 17:24:45 EST
This bug has already been fixed, however, I don't believe it 's in a LiveCD release at all.  It's actually rather tricky to boot and get a display to be able to install + update to a kernel with the fix.  The best bet would be if there's a LiveCD of some sort available with a recent F12 2.6.32 kernel.  Adam?
Comment 5 Adam Williamson 2010-02-25 21:59:22 EST
we don't do rebuilds like that, but Fedora Unity does - http://fedoraunity.org/ . A future updated spin from them may do the trick.
Comment 8 Craig Anthony 2010-03-30 21:19:05 EDT
Unsurprisingly, this also affects T510 models.  The display goes blank at the point where the text mode menu would usually ask to check media or skip.  This result is the same with the default boot option or with basic video driver -- X is not yet running at this point.  The Fedora 13 Alpha media does not have this problem.  Would some vga= parameter help here or is there no way to install F12 without a rebuild?
Comment 9 Ben Skeggs 2010-03-30 21:34:45 EDT
There is, unfortunately, no way that I can think of.  The issue is caused by the nouveau module's load() function, so as soon as something tries to load nouveau.ko, the issue is triggered.

rdblacklist=nouveau lets you get further, but once udev kicks in, nouveau gets loaded anyway.
Comment 10 Jason Masker 2010-04-08 08:59:12 EDT
We have to pass the noprobe kernel parameter and then load the needed modules manually. Does anyone know what module is needed for the sata driver to get the DVD mounted?
Comment 11 Jason Masker 2010-04-08 12:56:56 EDT
Another work around for those of you trying to get this installed is to issue the "text" and "telnet" boot parameters and then use telnet & vnc from another machine to get through the install.
Comment 12 Werner Fischer 2010-04-15 02:23:04 EDT
Thanks for all of your valuable feedback. I'll wait for F13, which should fix the problem as Craig mentioned that F13 Alpha worked for him.

Note You need to log in before you can comment on or make changes to this bug.