Bug 56700 - kernel-2.4.9-13 panic on shutdown
kernel-2.4.9-13 panic on shutdown
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-25 08:58 EST by Thomas Ribbrock
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:49:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (5.58 KB, text/plain)
2001-11-25 09:01 EST, Thomas Ribbrock
no flags Details

  None (edit)
Description Thomas Ribbrock 2001-11-25 08:58:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
After updating the kernel from 2.4.7-10 to 2.4.9-13, I get a kernel panic
when running shutdown -h. The panic occurs right at the end of the shutdown
cycle while running "halt" (after unmounting files). This is on an AMD
K6-2/350 machine, VIA MVP3 chipset. The board is an AT board with AT power
supply, hence, there is no possibility ofatuomatically shutting the machine
down via software. I tried different BIOS APM/PM settings as well with no
difference. I had no such problems with kernel-2.4.7-10.

Version-Release number of selected component (if applicable):
kernel-2.4.9-13

How reproducible:
Always

Steps to Reproduce:
1.as root, run "shutdown -h now"
2.at end of shutdown,kernel panics

	

Expected Results:  Message "Power down." as with kernel-2.4.7-10

Additional info:
Comment 1 Thomas Ribbrock 2001-11-25 09:01:23 EST
Created attachment 38504 [details]
dmesg output
Comment 2 Thomas Ribbrock 2001-11-25 20:19:13 EST
Workaround:
It's possible to avoid the kernel panic by recompiling the kernel with APM/PM
disabled, as I just found out. However, due to the time it takes to do so,
having an RPM for non-APM kernel might be an idea.
Comment 3 Arjan van de Ven 2001-11-26 02:49:53 EST
Can you try passing "apm=realmode-power-off" as kernel commandline argument ?
That changes the way a poweroff is tried.

Also, if that doesn't work,

"apm=off" will disable apm

(both can be added to the /boot/grub/grub.conf file to the line with vmlinuz in it)
Comment 4 Alan Cox 2003-06-07 18:49:53 EDT
BIOS

Note You need to log in before you can comment on or make changes to this bug.