Bug 56710 - Sgml-tools does not parse correctly the .sgml of Grace. Use Linuxdoc instead
Sgml-tools does not parse correctly the .sgml of Grace. Use Linuxdoc instead
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sgml-tools (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-26 04:31 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 12:35:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-26 04:31:26 EST
Hello,

The sgml-tools do not parse correctly the .sgml of Grace 
(http://plasma-gate.weizmann.ac.il/Grace/)

sgml2latex  -o dvi-p a4 UserGuides.sgml (All the tables are screwed up)

It appears that the sgml-tools provided by RedHat 7.2 is from 1997...
Since then the package have been improved and BUGS have been corrected...
However the name of the package has changed. It is now called linuxdoc
I removed the sgml-tools package and replaced it with the Linuxdoc package
and now the .sgml are correctly parsed.

Can't RedHat replace sgml-tools by Linuxdoc?

Daniel
Comment 1 Tim Waugh 2001-11-26 06:15:37 EST
Sure.  I think most people have moved to DocBook now though.

Where is Linuxdoc?  www.sgmltools.org seems to be down.
Comment 2 Need Real Name 2001-11-26 06:57:41 EST
Hi,

It is there:
http://people.debian.org/~sano/linuxdoc-tools/

Daniel
Comment 3 Tim Waugh 2001-11-27 10:49:50 EST
Please take a look to check that the package I made is okay.
ftp://people.redhat.com/twaugh/tmp/linuxdoc-tools/

Comment 4 Need Real Name 2001-11-27 11:22:38 EST
I can build the package but the program does not work.
If you try linuxdoc -o dvi xxx.sgml (whatever xxx.sgml is) it does not even want
to start.
Here I had 0.9.10 and it worked.

If you try sgml2latex for instance it complains also:
The best test examples are the one provided by the package by itself:
example.sgml and guide.sgml


[root@brest mini]# sgml2latex -o dvi RPM+Slackware.sgml 
Processing file RPM+Slackware.sgml
load_char_maps: no entity maps found
load_char_maps: no entity maps found
parse_data: no entity map for `urlnam'
This is TeX, Version 3.14159 (Web2C 7.3.1)
LaTeX2e <2000/06/01>....


Daniel
Comment 5 Tim Waugh 2001-11-27 12:02:33 EST
The packaging in linuxdoc-tools seems to be even worse than sgml-tools was. :-(

'./configure --datadir=/tmp/... && make' fails in several different ways.  I 
have sent one large fix to the upstream maintainer.  The package still 
requires autoconf to build though(!).  If only they knew about automake..

Anyhow, please try the new package that I put in that directory.  It works for 
me with the examples you've given.
Comment 6 Need Real Name 2001-11-28 03:59:34 EST
I have been looking in the director you specified. It is still the -1 package
over there. I downloaded it and tried it, in case of you simply had forgotten to
change it to -2, but it behaves the same than previously.
I came to the conclusion that this package is not the one you are referring to
in your last comment.

Daniel
Comment 7 Tim Waugh 2001-11-28 05:36:02 EST
Yes, it's -1 but with a newer timestamp.  Can you show me the command you are 
running and the output you get vs expect?
Comment 8 Need Real Name 2001-11-28 05:41:32 EST
Hello. Here is what I got

		Daniel


[root@brest linuxdoc-tools-0.9.13]# ls
COPYRIGHT  example  guide.sgml  guide.txt  html  Makedoc.sh  README
[root@brest linuxdoc-tools-0.9.13]# linuxdoc -o dvi guide.sgml 
LinuxDoc-Tools version 0.9.13

Usage:
  linuxdoc [options] <infile>

General options:
  --backend={html,info,latex,lyx,rtf,txt,check} -B
{html,info,latex,lyx,rtf,txt,check}
  --papersize={a4,letter} -p {a4,letter}
 
--language={en,english,english,de,deutsch,german,nl,nederlands,dutch,fr,frangais,french,es,espaqol,spanish,da,dansk,danish,no,norsk,norwegian,se,svenska,swedish,pt,portuges,portuguese,ca,catal`,catalan,it,italiano,italian,ro,rombnc,romanian,ja,japanese,japanese,pl,polski,polish,ko,korean,korean}
-l
{en,english,english,de,deutsch,german,nl,nederlands,dutch,fr,frangais,french,es,espaqol,spanish,da,dansk,danish,no,norsk,norwegian,se,svenska,swedish,pt,portuges,portuguese,ca,catal`,catalan,it,italiano,italian,ro,rombnc,romanian,ja,japanese,japanese,pl,polski,polish,ko,korean,korean}
  --charset={latin,ascii,nippon,euc-kr} -c {latin,ascii,nippon,euc-kr}
  --style=string -S string
  --tabsize=number -t number
  --debug -d
  --define=string -D string
  --include=string -i string
  --pass=string -P string

Format: html
  --split={0,1,2} -s {0,1,2}
  --toc={0,1,2} -T {0,1,2}
  --dosnames -h
  --imagebuttons -I
  --header=string -H string
  --footer=string -F string

Format: info

Format: latex2e
  Note that this output format requires LaTeX 2e.

  --output={dvi,tex,ps,pdf} -o {dvi,tex,ps,pdf}
  --bibtex -b
  --makeindex -m
  --pagenumber=number -n number
  --quick -q
  --dvips={dvips,dvi2ps,jdvi2kps} -s {dvips,dvi2ps,jdvi2kps}
  --latex={latex,hlatexp,platex,jlatex} -x {latex,hlatexp,platex,jlatex}

Format: lyx

Format: rtf
  --twosplit -2

Format: txt
  --manpage -m
  --filter -f
  --blanks=number -b number

[root@brest linuxdoc-tools-0.9.13]# 
Comment 9 Need Real Name 2001-11-28 05:45:16 EST
Sorry. I was wrong.
I corrected what I wrote but I do not get a better result:

[root@brest i386]# linuxdoc --backend=latex -o dvi guide.sgml 
Processing file guide.sgml
Cannot find .//guide.SGML
[root@brest i386]# 
Comment 10 Tim Waugh 2001-11-28 05:48:45 EST
Is there a 'guide.sgml' in the 'i386' directory you're in?  A moment ago you 
were in 'linuxdoc-tools-0.9.13'...

Comment 11 Need Real Name 2001-11-28 05:53:05 EST
Ooops....
Sorry. I was in the wrong directory... 

Now Linuxdoc works with the guide.sgml file
and sgml2latex works also.

After my lunchtime I will try with the .sgml files from Grace

Thanks for your help and once again, sorry for having misunderstood the commands
of linuxdoc
Comment 12 Need Real Name 2001-11-28 07:31:16 EST
I tried with the .sgml of Xmgrace and it worked. So, for me, so far so good.
Thanks for your help.

One last thing that is important (in my opinion) is to mention in the next
release of RedHat that linuxdoc replaces now sgml-tools (it is pretty hard to
make a relation between these 2 packages just with the names...)

Thanks for your help.

Bye

Daniel
Comment 13 Tim Waugh 2001-12-04 10:16:21 EST
0.9.15-1 is in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.