Bug 567116 - gnome-shell cannot run
gnome-shell cannot run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Triaged
: 578127 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-02-21 13:16 EST by Bastien Nocera
Modified: 2010-05-09 19:58 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-15 17:03:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2010-02-21 13:16:21 EST
gnome-shell-2.28.1-0.1.20100128git.x86_64
json-glib-0.10.0-3.fc13.x86_64
clutter-1.1.10-2.fc13.x86_64

gnome-shell can't run with the current clutter, as Clutter json isn't used anymore, and clutter now requires json-glib.

gnome-shell needs:
- to require json-glib
- be updated to use Json instead of ClutterJson
Comment 1 Bastien Nocera 2010-02-21 13:17:31 EST
The error message looks something like:

    JS ERROR: !!!   Exception was: Error: Requiring Clutter, version none: Typelib file for namespace 'Json', version '1.0' not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Clutter, version none: Typelib file for namespace 'Json', version '1.0' not found")@:0
("Requiring Clutter, version none: Typelib file for namespace 'Json', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:3
Comment 2 Adam Williamson 2010-02-23 13:37:37 EST
yup, been seeing this for a few days. Looks like this here:

    JS ERROR: !!!   Exception was: Error: Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found")@:0
("Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:11
'
    JS ERROR: !!!     message = 'Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found'
    JS ERROR: !!!   Exception was: Error: Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found")@:0
("Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:11
Error("Chained exception")@:0
("Chained exception")@gjs_throw:0
@<main>:1
'
    JS ERROR: !!!     message = 'Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found'
Window manager warning: Log level 32: Execution of main.js threw exception: Error: Requiring Shell, version none: Typelib file for namespace 'ClutterJson', version '1.0' not found
Comment 3 Bruce Cowan 2010-02-27 18:15:53 EST
The build at http://koji.fedoraproject.org/koji/buildinfo?buildID=157881 fixes this.
Comment 4 Bastien Nocera 2010-03-03 05:36:53 EST
The build fixes *those* warnings, but it doesn't work properly still. Porting to Clutter 1.1.x (or rather, 1.2.x now) are under way.
Comment 5 Cia Watson 2010-03-11 11:34:21 EST
Is this related to this message I've gotten when yumex starts and when I brought up gedit in a desktop terminal window:

(gedit:2257): Gtk-WARNING **: Theme directory 256x256/status;scalable/apps of theme gnome has no size field

I suspect that's why my navigation buttons in various applications are all grey on grey, too? Or is this something different? I haven't done a search yet, I just got here from the F13 bugs page.
Comment 6 Adam Williamson 2010-03-11 17:11:37 EST
No, I don't think that's at all related.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Norman 2010-03-22 12:42:51 EDT
Gnome Shell is still broken:

Installed Packages
clutter.i686                     1.2.2-1.fc14                           @rawhide
gnome-shell.i686                 2.28.1-0.1.20100128git                 @fedora 
json-glib.i686                   0.10.4-1.fc14                          @rawhide


The Beta Freeze is tomorrow.
Will this be fixed soon?
Comment 8 Norman 2010-03-24 10:34:40 EDT
Gnome Shell is still broken:

Installed Packages
clutter.i686                 1.2.2-1.fc13                       @updates-testing
gnome-shell.i686             2.28.1-0.1.20100128git             @fedora         
mutter.i686                  2.29.0-2.fc13                      @updates-testing
Comment 9 Bruce Cowan 2010-03-24 13:10:48 EDT
It will be broken until gnome-shell is updated to 2.29.1, as it's the first that requires Clutter 1.2.
Comment 10 Norman 2010-04-01 04:44:47 EDT
GNOME 2.30 released.
Comment 11 Colin Walters 2010-04-01 11:39:51 EDT
*** Bug 578127 has been marked as a duplicate of this bug. ***
Comment 12 Norman 2010-04-02 04:53:11 EDT
Still not working after updating to Gnome 2.30.
Comment 13 David Le Sage 2010-04-06 03:12:10 EDT
I am running a manually installed version of gnome-shell 2.29.1 and I had the same error as Adam WIlliamson and Bastien Nocera above when I clicked on the Activities menu.
Comment 15 Adam Williamson 2010-04-06 13:19:15 EDT
Thanks, Colin. As a note, if those three packages are interconnected, it would be best to submit them as a single update, so there's no chance one can get pushed without the others.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 David Le Sage 2010-04-06 18:19:41 EDT
Colin, I just installed the RPMs linked above and whilst Gnome-Shell loads, it still cannot do anything. Clicking on the Activities menu highlights it but does nothing else whilst no windows can be maximised or minimised or moved once it is started.

Process I used:

1. Running standard Fedora 13 with daily yum updates.
2. Install the 4 RPMS listed above.
3. As normal user, System->Preferences->Desktop Effects->Gnome Shell

Results:
Shell launches but cannot do anything.  Only clock/calendar drop-down and Alt-F2 seem to work.
Comment 17 David Le Sage 2010-04-06 18:25:16 EDT
Further info:  Just tried running it from Bash and it didn't load at all:


[dlesage@localhost ~]$ gnome-shell --replace
      JS LOG: GNOME Shell started at Wed Apr 07 2010 08:25:21 GMT+1000 (EST)
      JS LOG: Failed to acquire org.freedesktop.Notifications; trying again



I am not a dev but I am happy to give feedback and do a little testing in between my normal duties for RH if it helps you.
Comment 18 David Le Sage 2010-04-06 18:39:15 EDT
Further info:  I just tried running it again via the graphical method and it failed to load at all.  I had an Xterm already open and this error message appeared in it:


[dlesage@localhost ~]$ Panel leaving: a new panel shell is starting.

(gnome-panel:22061): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed
Comment 19 David Le Sage 2010-04-06 18:49:27 EDT
Ran it again from the Shell, this time with Compiz already switched on.  Gnome-Shell's top panel wouldn't launch but Alt-F2 worked, Alt-Tab worked and windows could be dragged.

Output as follows:


[dlesage@localhost ~]$ gnome-shell --replace
      JS LOG: GNOME Shell started at Wed Apr 07 2010 08:47:09 GMT+1000 (EST)

(mutter:22600): Clutter-WARNING **: The actor 'ShellGenericContainer' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(mutter:22600): Clutter-WARNING **: The actor 'StBin' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(mutter:22600): Clutter-WARNING **: The actor 'StBoxLayout' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(mutter:22600): Clutter-WARNING **: The actor 'ShellGenericContainer' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

****

When I attempted to exit via Ctrl-C, I encountered the following message:

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Comment 20 David Le Sage 2010-04-07 00:57:29 EDT
It seems to be that when the user clicks on Activities, Alt-Tab and window resizing lock up.  If the user does not click on Activities, it all works.


Most apps can be launched from Alt-F2, apart from Firefox, OO.org Writer and banshee-1, all of which crash the software.

If these are avoided, it works well. I have tried out the sidebar, launched Looking Glass and a few other things and all of these are working for me with this build under F13.
Comment 21 Colin Walters 2010-04-08 20:38:39 EDT
Hi David,

It sounds like a graphic driver issue of some sort, but it's hard to be sure without additional information.  Do you have a Smolt profile online?

Also could you remove the -1 from the bodhi update?  It's not a regression from the previous release, and honestly, there's just no way I'm going to have time to debug it before beta, and it's known to work for others.
Comment 22 David Le Sage 2010-04-08 21:03:19 EDT
Hello Colin,


Firstly, thanks for looking into this.  No, I don't have a Smolt profile but I am happy to supply you with any graphical driver info you need.  I am running an IBM T500, which is standard hardware at present at RH in Brisbane, so this would potentially effect anyone here keen to try out GNOME-Shell.



At present, I am running GNOME-Shell and it is stable as long as I do not click "activities" based on the RPM I grabbed and manually installed from  

https://admin.fedoraproject.org/updates/gnome-shell-2.29.1-4

as per your recommendation.


If Activities is clicked, the lock ups occur.  Alt-F2 is the only thing that still functions when it "locks", so I can just type "r" to restart it.  


I have discovered that the crashes I cited above, regarding Banshee, Firefox and OO.org would only occur after I had tried to launch them from alt-F2 having already clicked Activities (whilst Activities would freeze most functionality, trying to run these apps would kill GNOME Shell altogether and it would fall back to the "old" GNOME Panel.)

If I launch Firefox, etc, from alt-F2 without having tried Activities, these apps will launch without any problems.


Please let me know any info you need from config files, etc, and I will be more than happy to supply it.  Cheers and thanks for looking into this.
Comment 25 David Le Sage 2010-04-09 06:27:31 EDT
Colin,


Good news.  I did a full system reboot this evening and I find that I can now use the Activity menu without any locks or freezers.  Everything appears to be working perfectly.  My issues are now resolved and I can start to use GNOME-shell.


Many thanks.
Comment 26 Colin Walters 2010-04-09 09:11:32 EDT
David, that's great!  Thanks a lot for testing.
Comment 29 Colin Walters 2010-04-15 17:03:40 EDT
Closing this bug as the core should run now; any hardware-dependent issues need to be addressed separately.

Note You need to log in before you can comment on or make changes to this bug.