Bug 56721 - K12LTSP: bump loop detection to 250/s
Summary: K12LTSP: bump loop detection to 250/s
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pxe   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-26 14:23 UTC by Jeff Johnson
Modified: 2007-04-18 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 17:41:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Johnson 2001-11-26 14:23:26 UTC
Please bump the loop detection to 250/sec in order to
support PXE boots from thin clients:

Here's the change:

108a109,112
> * Wed Oct 24 2001 Eric Harrison <eharrison@mesd.k12.or.us>
> - LTSP HACK: bumped up loop detection to 250/second: PXE booting
>   can be pretty hard on xinetd.
> 
diff xinetd-7.2/xinetd.sysconf xinetd/xinetd.sysconf
2c2
< EXTRAOPTIONS=""
---
> EXTRAOPTIONS="-loop 250"

Comment 1 Trond Eivind Glomsrxd 2001-11-26 21:33:16 UTC
Uh... why? It's a configuration option. It's not impossible to do afterwards,
and if implemented would limit the usefulness of loop detections in the first
place. A special case for use often needs a little configuration.



Comment 2 Jeff Johnson 2001-11-26 21:47:49 UTC
Um, please remember I'm just the messanger here.

Because thin clients have different needs, and, particularly in
the case of k12ltsp, removing some of the deeper darker
configuration voo-doo is gonna be neccessary.

Please feel free to suggest a better number than 250 if you wish.
However, understand that the number was arrived at with
Real World PXE booting experience, something we are sorely
lacking in at the moment.

Comment 3 Rob Braun 2001-12-03 01:16:36 UTC
The loop detection in 2.3.3 and earlier is clumsy, and duplicates some of the 
functionality in the configuration section.  It's clumsy because the -loop 
option is passed on the command line and can't be overridden in the config 
file.

The current development branch of xinetd removed the -loop option, since the 
per-service 'cps' directive (connections per second) duplicated much of the 
purpose of -loop, but is more configurable.  It still defaults to on, with the 
old compiled defaults, but is at least configurable now.


Comment 4 Trond Eivind Glomsrxd 2001-12-06 17:40:34 UTC
The current rawhide version of xinetd is based on that snapshot. Reassigning to
pxe - if there is a desire to change the defaults for that package, it can be done.

Comment 5 Elliot Lee 2002-01-29 22:38:47 UTC
Leaving defaults as-is


Note You need to log in before you can comment on or make changes to this bug.