Bug 567228 - No java plugin in firefox
No java plugin in firefox
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Martin Matejovic
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-02-22 06:35 EST by Nicolas Mailhot
Modified: 2010-03-23 19:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-15 05:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-02-22 06:35:01 EST
Description of problem:

The java plugin filename changed but alternative rules were not updated ; as a result it is no longer registered in firefox

java-1.6.0-openjdk-plugin-1:1.6.0.0-34.b17.fc13.x86_64

$ ls -l /usr/lib64/mozilla/plugins/libjavaplugin.so 
lrwxrwxrwx. 1 root root 41 19 févr. 10:49 /usr/lib64/mozilla/plugins/libjavaplugin.so -> /etc/alternatives/libjavaplugin.so.x86_64

$ ls -l /etc/alternatives/libjavaplugin.so.x86_64
lrwxrwxrwx. 1 root root 64 19 févr. 10:49 /etc/alternatives/libjavaplugin.so.x86_64 -> /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so

$ rpm -ql java-1.6.0-openjdk-plugin
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/IcedTeaNPPlugin.so
Comment 1 Adam Williamson 2010-02-22 14:18:10 EST
Confirmed here. It seems the spec file had the new name of the file added to the list that alternatives uses, but that's not enough: as long as the old name is still listed, alternatives will continue to use it, even if the file doesn't exist:

[root@adam F-13]# update-alternatives --display libjavaplugin.so.x86_64
libjavaplugin.so.x86_64 - status is auto.
 link currently points to /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so
/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so - priority 16000
/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaNPPlugin.so - priority 16000
Current `best' version is /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so.

either the old name should be removed in %post, or the new name should be given a higher priority, I guess.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2010-02-22 14:19:07 EST
workaround is 'update-alternatives --config libjavaplugin.so.x86_64' (or .i586 or something on 32-bit, I guess) and then pick the appropriate option (should be 2).
Comment 3 Deepak Bhole 2010-02-22 21:34:58 EST
Hmm, odd. The IcedTeaPlugin.so alternative should have gotten removed during upgrade.

Re-assigning to Fedora RPM owner.
Comment 5 Adam Williamson 2010-02-23 15:47:05 EST
deepak: I only glanced at the spec, but it looks like there's nothing there to remove the old name, that I could see anyway.
Comment 6 Fedora Update System 2010-03-13 12:51:32 EST
java-1.6.0-openjdk-1.6.0.0-33.b17.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-33.b17.fc11
Comment 7 Fedora Update System 2010-03-13 12:53:46 EST
java-1.6.0-openjdk-1.6.0.0-36.b17.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-36.b17.fc12
Comment 8 Fedora Update System 2010-03-15 05:29:15 EDT
java-1.6.0-openjdk-1.6.0.0-35.b17.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-35.b17.fc13
Comment 9 Fedora Update System 2010-03-15 20:40:58 EDT
java-1.6.0-openjdk-1.6.0.0-33.b17.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-03-15 20:45:04 EDT
java-1.6.0-openjdk-1.6.0.0-36.b17.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-03-23 19:27:41 EDT
java-1.6.0-openjdk-1.6.0.0-35.b17.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.