This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 567231 - rpmlint macro-in-%description / unexpanded-macro %description seems wrong when we use %% to mean a percent sign
rpmlint macro-in-%description / unexpanded-macro %description seems wrong whe...
Status: CLOSED DUPLICATE of bug 551366
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-22 06:47 EST by Richard W.M. Jones
Modified: 2010-02-22 12:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-22 12:38:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-02-22 06:47:25 EST
Description of problem:

I have an RPM %description that contains this text:

%description
[..]
In order to get access to the hive files themselves, you can copy them
from a Windows machine.  They are usually found in
%%systemroot%%\system32\config.  For virtual machines we recommend
[..]

RPM itself correctly converts the double percent signs to single percent
signs, ie:

$ rpm -qip /home/rjones/rpmbuild/SRPMS/hivex-1.1.2-1.fc12.src.rpm
[..]
In order to get access to the hive files themselves, you can copy them
from a Windows machine.  They are usually found in
%systemroot%\system32\config.  For virtual machines we recommend

However rpmlint gives a warning:

hivex.src: W: macro-in-%description %systemroot

I think this warning is wrong.

Version-Release number of selected component (if applicable):

rpmlint-0.91-1.fc12.noarch

rpmlint-0.94-1.fc13.noarch gives a slightly different warning:

hivex.src: W: unexpanded-macro %description -l C %systemroot

How reproducible:

Always.

Steps to Reproduce:
1. Use %%systemroot%% in a description.
2. Build the RPM.
3. Compare RPM output to rpmlint output.

Additional info:

I cannot find any documentation on the correct use of escaping
in RPM spec files...
Comment 1 Ville Skyttä 2010-02-22 12:38:39 EST

*** This bug has been marked as a duplicate of bug 551366 ***

Note You need to log in before you can comment on or make changes to this bug.