This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 567260 - dstat should be rebased in RHEL5
dstat should be rebased in RHEL5
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dstat (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Popelka
qe-baseos-daemons
: Rebase
Depends On:
Blocks: 5.6RelNotes
  Show dependency treegraph
 
Reported: 2010-02-22 08:25 EST by Jan Zeleny
Modified: 2010-12-22 08:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
- Stability, exception and procfs handling improvements - Improvements to plugin interface - Improvements to dstat and plugin performance - Improvements to usability and documentation - More accurate scheduler - Theming support - Options to debug and baseline performance - Various fixes to irregularities in time-keeping - Many new plugins: -- top process monitoring -- per process latency and cputime plugins -- page faults, allocations and frees plugin: --vm -- disk utilization rate plugin: --disk-util -- disk i/o transaction plugin: --disk-tps -- baseline dstat plugin: --dstat -- mysql and mysql5 plugins -- network plugin: --net-packets -- lustre plugin: --lustre -- filesystem plugin: --fs -- socket plugin: --socket -- aio plugin: --aio -- io plugin: --io -- vmware plugins: --vmmemctl -- ntp plugin: --ntp -- power usage plugin: --power -- battery time plugin: --battery-remain -- fan plugin: --fan -- process count plugin: --proccount -- openvz io plugin: --vzio -- memcache plugin: --memcache -- qmail plugin: --qmail -- accuracy plugin: --snooze
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-22 08:45:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Zeleny 2010-02-22 08:25:54 EST
From a brief consultation with upstream developer an observation that this component should be rebased came up.

Version in RHEL5: 0.6.6-3.el5_4.1 (released 28/04/2007)
Latest version: 0.7.1 (released today)

Important differences (details in ChangeLog):

  - Improvements to stability, exception handling, procfs handling
  - Improvements to plugin interface
  - Improvements to dstat and plugin performance
  - Improvements to usability and documentation
    - Plugins now use long options
    - Better hints when eg. no options have been specified
    - Option --float to show floating point results when possible
  - More accurate scheduler (better accuracy than vmstat/iostat)
  - Theming support (eg. for using on white background terminals --bw)
  - Options to debug and baseline performance (--debug, --dstat, --snooze, --profile)
  - Various fixes to irregularities in time-keeping (reports missing ticks)
    - May happen when virtualized, hibernated or high latency
  - Many new plugins:
     - top process monitoring: --top-io, --top-bio, --top-oom, --top-mem, --top-cpu
     - per process latency and cputime plugins: --top-latency(-avg), --top-cputime(-avg)
     - page faults, allocations and frees plugin: --vm
     - disk utilization rate plugin: --disk-util
     - disk i/o transaction plugin: --disk-tps
     - baseline dstat plugin: --dstat
     - mysql and mysql5 plugins
     - network plugin: --net-packets
     - lustre plugin: --lustre
     - filesystem plugin: --fs
     - socket plugin: --socket
     - aio plugin: --aio
     - io plugin: --io
     - vmware plugins: --vmmemctl
     - ntp plugin: --ntp
     - power usage plugin: --power
     - battery time plugin: --battery-remain
     - fan plugin: --fan
     - process count plugin: --proccount
     - openvz io plugin: --vzio
     - memcache plugin: --memcache
     - qmail plugin: --qmail
     - accuracy plugin: --snooze

Some of these plugins increase the usefulness of dstat, especially the 
latency, disk and i/o plugins are a lifesaver. I always advertised dstat 
as a modern replacement to vmstat, iostat and ifstat, but it's only after 
the --disk-util and --disk-tps plugins that we're on par with iostat.

These plugins make a huge difference in functionality if dstat is to be considered a valuable tool for doing system performance analysis.
Comment 2 Jan Zeleny 2010-02-22 10:30:14 EST
I copied the changelog from description to technical notes.

Also it should be mentioned, that the new version has been tested on RHEL5 by upstream developer.
Comment 3 Jan Zeleny 2010-02-22 10:30:14 EST
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
- Stability, exception and procfs handling improvements
- Improvements to plugin interface
- Improvements to dstat and plugin performance
- Improvements to usability and documentation
- More accurate scheduler
- Theming support
- Options to debug and baseline performance
- Various fixes to irregularities in time-keeping
- Many new plugins:
-- top process monitoring
-- per process latency and cputime plugins
-- page faults, allocations and frees plugin: --vm
-- disk utilization rate plugin: --disk-util
-- disk i/o transaction plugin: --disk-tps
-- baseline dstat plugin: --dstat
-- mysql and mysql5 plugins
-- network plugin: --net-packets
-- lustre plugin: --lustre
-- filesystem plugin: --fs
-- socket plugin: --socket
-- aio plugin: --aio
-- io plugin: --io
-- vmware plugins: --vmmemctl
-- ntp plugin: --ntp
-- power usage plugin: --power
-- battery time plugin: --battery-remain
-- fan plugin: --fan
-- process count plugin: --proccount
-- openvz io plugin: --vzio
-- memcache plugin: --memcache
-- qmail plugin: --qmail
-- accuracy plugin: --snooze
Comment 5 RHEL Product and Program Management 2010-08-09 15:13:14 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2010-12-22 08:45:23 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.