Bug 567262 - SIGSEGV error in zarafa-server with DB authentication
Summary: SIGSEGV error in zarafa-server with DB authentication
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zarafa
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-22 13:28 UTC by Robert Scheck
Modified: 2010-03-16 19:34 UTC (History)
4 users (show)

Fixed In Version: zarafa-6.30.10-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-26 11:49:17 UTC


Attachments (Terms of Use)
Remerged changeset of Subversion Revision 18952 from 6.40.0 (trunk) to 6.30.10 (1.45 KB, patch)
2010-02-22 16:27 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2010-02-22 13:28:32 UTC
Description of problem:
When trying to create a user with DB authentication using zarafa-admin, the 
zarafa-server crashes with a SIGSEGV error.

Version-Release number of selected component (if applicable):
libmapi-6.30.10-1.fc12.x86_64
zarafa-monitor-6.30.10-1.fc12.x86_64
zarafa-server-6.30.10-1.fc12.x86_64
zarafa-ical-6.30.10-1.fc12.x86_64
php-mapi-6.30.10-1.fc12.x86_64
zarafa-6.30.10-1.fc12.x86_64
zarafa-dagent-6.30.10-1.fc12.x86_64
zarafa-debuginfo-6.30.10-1.fc12.x86_64
zarafa-spooler-6.30.10-1.fc12.x86_64
zarafa-gateway-6.30.10-1.fc12.x86_64
zarafa-utils-6.30.10-1.fc12.x86_64
zarafa-common-6.30.10-1.fc12.x86_64
zarafa-client-6.30.10-1.fc12.x86_64
zarafa-webaccess-6.30.10-1.fc12.noarch

How reproducible:
Everytime, see above and below.

Steps to Reproduce:
1. yum --enablerepo=updates-testing install zarafa
2. gdb /usr/bin/zarafa-server
3. run -F
4. (on another console, type): "zarafa-admin -c tux -e tux@localhost -f 'Tux' -p secure"
  
Actual results:
SIGSEGV error in zarafa-server with DB authentication

Expected results:
No segmentation fault when using zarafa-admin

Additional info:
Mo 22 Feb 2010 13:21:13 CET: Caught SIGSEGV (6), traceback:
Mo 22 Feb 2010 13:21:13 CET: 0x000000004735ab /usr/bin/zarafa-server(_Z7sigsegvi+0x4b) [0x4735ab]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb80f0f0 /lib64/libpthread.so.0() [0x39fb80f0f0]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb0326c5 /lib64/libc.so.6(gsignal+0x35) [0x39fb0326c5]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb033ea5 /lib64/libc.so.6(abort+0x175) [0x39fb033ea5]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb06f0f3 /lib64/libc.so.6() [0x39fb06f0f3]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb0f75e7 /lib64/libc.so.6(__fortify_fail+0x37) [0x39fb0f75e7]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb0f5600 /lib64/libc.so.6() [0x39fb0f5600]
Mo 22 Feb 2010 13:21:13 CET: 0x00000000613dbb /usr/bin/zarafa-server(_Z13ABIDToEntryIDP4soapjRKSsmP17xsd__base64Binary+0x13b) [0x613dbb]
Mo 22 Feb 2010 13:21:13 CET: 0x000000004d2304 /usr/bin/zarafa-server(_Z12GetABEntryIDjP4soapP17xsd__base64Binary+0xf4) [0x4d2304]
Mo 22 Feb 2010 13:21:13 CET: 0x00000000519f14 /usr/bin/zarafa-server(_Z19ns__resolveUsernameP4soapyPcP19resolveUserResponse+0x444) [0x519f14]
Mo 22 Feb 2010 13:21:13 CET: 0x0000000060332d /usr/bin/zarafa-server(_Z30soap_serve_ns__resolveUsernameP4soap+0xad) [0x60332d]
Mo 22 Feb 2010 13:21:13 CET: 0x0000000060e244 /usr/bin/zarafa-server(_Z10soap_serveP4soap+0xa4) [0x60e244]
Mo 22 Feb 2010 13:21:13 CET: 0x00000000479758 /usr/bin/zarafa-server(_ZN22ECSoapServerConnection15process_requestEPv+0x78) [0x479758]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb806a3a /lib64/libpthread.so.0() [0x39fb806a3a]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb0de67d /lib64/libc.so.6(clone+0x6d) [0x39fb0de67d]
Mo 22 Feb 2010 13:21:13 CET: When reporting this traceback, please include Linux distribution name, system architecture and Zarafa version.
Mo 22 Feb 2010 13:21:13 CET: Caught SIGSEGV (11), traceback:
Mo 22 Feb 2010 13:21:13 CET: 0x000000004735ab /usr/bin/zarafa-server(_Z7sigsegvi+0x4b) [0x4735ab]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb80f0f0 /lib64/libpthread.so.0() [0x39fb80f0f0]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb0d73e3 /lib64/libc.so.6(__select+0x33) [0x39fb0d73e3]
Mo 22 Feb 2010 13:21:13 CET: 0x0000000047837a /usr/bin/zarafa-server(_ZN22ECSoapServerConnection6SelectEv+0x12a) [0x47837a]
Mo 22 Feb 2010 13:21:13 CET: 0x00000000477375 /usr/bin/zarafa-server(_Z14running_serverPcS_+0x1f95) [0x477375]
Mo 22 Feb 2010 13:21:13 CET: 0x00000000477dec /usr/bin/zarafa-server(main+0x5ec) [0x477dec]
Mo 22 Feb 2010 13:21:13 CET: 0x000039fb01eb1d /lib64/libc.so.6(__libc_start_main+0xfd) [0x39fb01eb1d]
Mo 22 Feb 2010 13:21:13 CET: 0x000000004731d9 /usr/bin/zarafa-server() [0x4731d9]
Mo 22 Feb 2010 13:21:13 CET: When reporting this traceback, please include Linux distribution name, system architecture and Zarafa version.

Comment 1 Robert Scheck 2010-02-22 16:26:35 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2005731 seems to contain
a working fix, please verify. Note that you need to drop your Zarafa database
again, because otherwise you can't create the same user (gets corrupted at
the zarafa-server crash as it seems).

Comment 2 Robert Scheck 2010-02-22 16:27:51 UTC
Created attachment 395505 [details]
Remerged changeset of Subversion Revision 18952 from 6.40.0 (trunk) to 6.30.10

Comment 3 Luca Foppiano 2010-02-22 16:57:17 UTC
I saw it and I'm gonna try...but looking at the version (not sure.), should be better to increase the revision number? 6.30.10-2 instead of having 6.30.10-1

Thanks
Luca

Comment 4 Robert Scheck 2010-02-22 17:01:42 UTC
Yes, you're of course right - sorry. Will do that the next time then.

The cause for this issue seems to be, that Zarafa doesn't honor a long-time
Fedora feature in their code: http://fedoraproject.org/wiki/Security/Features#Compile_Time_Buffer_Checks_.28FORTIFY_SOURCE.29

Comment 5 Fedora Update System 2010-02-23 21:45:07 UTC
zarafa-6.30.10-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.fc13

Comment 6 Fedora Update System 2010-02-23 21:45:31 UTC
zarafa-6.30.10-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.fc12

Comment 7 Fedora Update System 2010-02-23 21:45:56 UTC
zarafa-6.30.10-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.fc11

Comment 8 Fedora Update System 2010-02-23 21:46:18 UTC
zarafa-6.30.10-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/zarafa-6.30.10-2.el5

Comment 9 Fedora Update System 2010-02-24 08:00:18 UTC
zarafa-6.30.10-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2816

Comment 10 Fedora Update System 2010-02-24 17:35:22 UTC
zarafa-6.30.10-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-2312

Comment 11 Fedora Update System 2010-02-25 20:15:31 UTC
zarafa-6.30.10-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-2312

Comment 12 Fedora Update System 2010-02-25 20:18:54 UTC
zarafa-6.30.10-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2816

Comment 13 Fedora Update System 2010-02-26 03:41:00 UTC
zarafa-6.30.10-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2948

Comment 14 Fedora Update System 2010-02-26 03:46:05 UTC
zarafa-6.30.10-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zarafa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2958

Comment 15 Fedora Update System 2010-02-26 08:08:19 UTC
zarafa-6.30.10-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2958

Comment 16 Fedora Update System 2010-02-26 08:09:17 UTC
zarafa-6.30.10-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2948

Comment 17 Fedora Update System 2010-02-26 11:48:57 UTC
zarafa-6.30.10-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-02-27 03:32:20 UTC
zarafa-6.30.10-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-02-27 03:47:56 UTC
zarafa-6.30.10-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2010-03-16 19:34:10 UTC
zarafa-6.30.10-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.