Bug 567299 - Illegal GPL/Vera license mixing
Illegal GPL/Vera license mixing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: paktype-ajrak-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2010-02-22 10:38 EST by Nicolas Mailhot
Modified: 2010-03-22 03:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 03:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-02-22 10:38:11 EST
This font claims to be under the GPL, and incorporate Vera/Dejavu elements

Unfortunately the Vera License is not GPL-compatible. DejaVu additions are mostly in the public domain but separating them from the Vera core is not obvious and anyway what third-party fonts are interested in is usually the basic latin Vera core.

Therefore, unless upstream agrees to relicense the whole font under the Vera License, (assuming all the other parts in the font can be relicensed by upstream and are not derived from third-party GPL fonts) or drops Vera components from the font, we can not ship the result
Comment 1 Pravin Satpute 2010-02-23 00:35:06 EST
ohh, its serious issue
since this is mistake from upstream itself i will try to update them on this, and will request to update there license or remove Dejavu shapes
i think they can definitely get non-arabic glyphs from some other GPL fonts

alternately

i will ship back paktype-naqsh-fonts and paktype-tehreer fonts to previous version, where there was no license issues

and we will block ajrak fonts
Comment 2 Pravin Satpute 2010-03-03 11:48:35 EST
upstream released new tarball
fixed in paktype-ajrak-fonts-2.0-2.fc14

thanks for identifying this
Comment 3 Pravin Satpute 2010-03-22 03:22:21 EDT
please reopen if any problem
closing for now

Note You need to log in before you can comment on or make changes to this bug.