Bug 567318 - /usr/sbin/rpmconf: line 124: [: missing `]'
Summary: /usr/sbin/rpmconf: line 124: [: missing `]'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmconf
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-22 16:11 UTC by Michal Schmidt
Modified: 2010-02-23 16:07 UTC (History)
2 users (show)

Fixed In Version: rpmconf-0.2.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 16:07:20 UTC


Attachments (Terms of Use)

Description Michal Schmidt 2010-02-22 16:11:08 UTC
Description of problem:
Sometimes when using rpmconf this error appears:
/usr/sbin/rpmconf: line 124: [: missing `]'
It does not seem to be fatal though.

Version-Release number of selected component (if applicable):
rpmconf-0.2.1-1.fc13.noarch

How reproducible:
Easily, just let rpmconf discover a *.rpmsave file.

Additional info:

The buggy line looks like this:
while [ ... -a "$OPTION" != "M"]; do

Note that the mandatory last argument ']' must be separated by space from "M".

Comment 1 Miroslav Suchý 2010-02-22 17:30:29 UTC
Fixed in upstream repo in commit 6a24920d286fac546ced787023faa581e0892710

Comment 2 Miroslav Suchý 2010-02-22 17:49:30 UTC
Fixed in rpmconf-0.2.2-1

Comment 3 Fedora Update System 2010-02-22 18:00:45 UTC
rpmconf-0.2.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/rpmconf-0.2.2-1.fc13

Comment 4 Fedora Update System 2010-02-23 16:07:16 UTC
rpmconf-0.2.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.