Bug 567325 - ifd-egate uses deprecated udev rules syntax
ifd-egate uses deprecated udev rules syntax
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ifd-egate (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bob Relyea
Fedora Extras Quality Assurance
: Triaged
: 577530 583632 692666 (view as bug list)
Depends On: 579515
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-02-22 11:22 EST by Michal Schmidt
Modified: 2013-01-10 00:43 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 18:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2010-02-22 11:22:55 EST
Description of problem:

When udev starts in F-13 it prints several warnings:

Starting udev: udevd[483]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3

udevd[483]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3

udevd[483]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:5


Version-Release number of selected component (if applicable):
ifd-egate-0.05-22.x86_64
udev-151-3.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
Just boot.
  
Actual results:
The above warnings are printed during boot (and they can be reviewed later in /var/log/boot.log).

Expected results:
No warnings.
Comment 1 Bob Relyea 2010-03-01 13:32:01 EST
This bug will probably be resolved by orphaning ifd-egate. The upstream was long dead, and the hardware it support has not been available now for 4 years. 

Before I do, I just want to make sure that this bug is because of spurious warnings and not because someone is actively using the package.

bob
Comment 2 Michal Schmidt 2010-03-02 11:30:52 EST
I don't use ifd-egate. I have it installed only because it is a dependency of coolkey which is installed by default in the Base comps group.
Comment 3 Bob Relyea 2010-03-02 11:55:49 EST
OK, thanks. I've already removed coolkey's dependancy on ifd-egate in f13 and f14 in preparation of orphaning it.

bob
Comment 4 Matthias Clasen 2010-03-02 13:39:15 EST
Don't forget to add an obsoletes somewhere (probably coolkey ?) when orphaning it, so it actually gets removed from existing installations.
Comment 5 Christopher Beland 2010-04-02 18:10:20 EDT
*** Bug 577530 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Beland 2010-04-02 18:18:44 EDT
This is still causing startup errors as of post-Beta F13
desktop-x86_64-20100401.18.iso.
Comment 7 Hans de Goede 2010-04-14 03:32:07 EDT
Ping? This is still happening with installs of yesterdays F-13 tree, please fix!
Comment 8 Adam Williamson 2010-04-16 12:34:13 EDT
Bob, as well as building a new coolkey which removes the dependency, you need to submit it as an update for F13, just as you would for a released version. This is the new process under NFR. Thanks!

I've asked the esc maintainer to do the same, then we should be able to orphan ifd-egate and close this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Bob Relyea 2010-04-19 13:13:59 EDT
*** Bug 583632 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2010-04-23 13:45:41 EDT
Again, Bob (and also Jack) - could you please submit the coolkey update to Bodhi for F13 ASAP so we can get rid of ifd-egate and close off this Fedora 13 blocker bug? Thank you.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Bob Relyea 2010-04-23 14:22:31 EDT
I guess I was confused about the process. I thought the build I made in F-13 was already pushed, but I just checked and it was only in candidate-updates. I just pushed it to stable from bodhi (hopefully that was the correct thing).

bob
Comment 12 Adam Williamson 2010-04-23 21:14:11 EDT
well, nearly :). prior to that you hadn't submitted it as a testing update at all. you've just submitted it straight to stable without sending it through testing. practically speaking that'll likely be fine for such a small change, but we've been trying to discourage people from doing it recently.

the process for 'branched' - the upcoming stable release once it's split off from rawhide, under the No Frozen Rawhide system - is now identical to that for stable releases, if it helps any. You should first submit the update for testing and then, after you get positive feedback on it (or no negative feedback for a decent amount of time), submit it to stable. Just doing the build isn't enough to submit it to testing, that's a distinct step you can do manually or with the help of the buildsystem (there's a 'make' call for it iirc).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Adam Williamson 2010-05-03 10:44:59 EDT
Bob: esc update has now been pushed to stable, so you should be able to orphan this. Can you please do so? Thanks!

Jesse: nothing should have an unavoidable dependency on ifd-egate any more, so we can block it from composes to remove the blocker-iness of the bug at this stage.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Bob Relyea 2010-05-03 14:40:29 EDT
It should already be orphaned, It just needs to be deleted now. I think a proven packager needs to do that?

bob
Comment 15 Jesse Keating 2010-05-03 18:44:37 EDT
Blocked.
Comment 16 Eddie Lania 2010-05-28 14:55:10 EDT
Just upgraded from F12 -> F13, it isn't removed.
Comment 17 Adam Williamson 2010-05-28 15:01:08 EDT
it wouldn't be, upgrades do not automatically remove orphaned packages.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Josh Boyer 2011-09-15 07:58:16 EDT
*** Bug 692666 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.