Bug 56734 - patch to make the ftpclient actually compile
Summary: patch to make the ftpclient actually compile
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: Patches and contributions   
(Show other bugs)
Version: CVS
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Larmour
QA Contact: Jonathan Larmour
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-26 17:37 UTC by Andrew Lunn
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-04 23:41:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to make the ftpclient compile (4.36 KB, patch)
2001-11-26 17:38 UTC, Andrew Lunn
no flags Details | Diff

Description Andrew Lunn 2001-11-26 17:37:33 UTC
Description of Problem:

The ftpclient code i contributed was for eCos 1.5.2. It seems it was just
dropped into anoncvs eCos an never tested. It does not compile because of
two changes between 1.5.2 and the current anoncvs version....

1) gethostbyname no longer exists. This bit of code needs to be conditional
on the NS_DNS package.

2) diag_printf has been rewritten to use varargs where as my code used the
old array method.

Attached is a patch to fix these two problems. It at least compiles now.

Comment 1 Andrew Lunn 2001-11-26 17:38:32 UTC
Created attachment 38624 [details]
Patch to make the ftpclient compile

Comment 2 Jonathan Larmour 2001-12-04 23:41:25 UTC
I've applied the patch verbatim now. You'll see it in the next anoncvs update. I
should probably have a closer look at this package sometime, but at least it's
there for now :-).

Thanks!



Comment 3 Jonathan Larmour 2002-01-03 21:26:41 UTC
No complaints....


Note You need to log in before you can comment on or make changes to this bug.