Bug 567343 - xulrunner insufficiently linked
xulrunner insufficiently linked
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
16
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 564811
  Show dependency treegraph
 
Reported: 2010-02-22 12:28 EST by Matthias Clasen
Modified: 2012-12-21 08:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-21 08:57:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2010-02-22 12:28:59 EST
I'm seeing this trying to build yelp:

/bin/sh ../libtool --tag=CXX   --mode=link g++ -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-unix-print-2.0 -I/usr/include/gtk-2.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/startup-notification-1.0 -I/usr/include/rarian   -pthread -I/usr/include/libbeagle -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include   -DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4   -DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4   -DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4   -fno-rtti  -fshort-wchar -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -Wno-unused  -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic    -o yelp yelp-Yelper.o yelp-yelp-base.o yelp-yelp-bookmarks.o yelp-yelp-debug.o yelp-yelp-error.o yelp-yelp-gecko-utils.o yelp-yelp-html.o yelp-yelp-io-channel.o yelp-yelp-settings.o yelp-yelp-utils.o yelp-yelp-window.o yelp-yelp-marshal.o yelp-yelp-main.o yelp-yelp-print.o yelp-yelp-page.o yelp-yelp-transform.o yelp-yelp-gecko-services.o yelp-yelp-document.o yelp-yelp-toc.o yelp-yelp-docbook.o yelp-yelp-db-print.o yelp-yelp-mallard.o yelp-yelp-man-parser.o yelp-yelp-man.o yelp-yelp-info.o yelp-yelp-info-parser.o yelp-gtkentryaction.o yelp-yelp-search.o yelp-yelp-search-parser.o yelp-eggdesktopfile.o yelp-eggsmclient.o yelp-eggsmclient-xsmp.o   -pthread -L/lib64 -lgconf-2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgmodule-2.0 -lexslt -lxslt -lz -lm -lgcrypt -ldl -lgpg-error -lxml2 -lstartup-notification-1 -ldbus-glib-1 -ldbus-1 -lpthread -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lrarian   -pthread -lbeagle -lxml2 -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0    -lz -lbz2  -lSM -lICE  -lX11  -L/usr/lib64/xulrunner-sdk-1.9.2/lib -lxpcomglue -lplds4 -lplc4 -lnspr4 -lpthread -ldl    -L/usr/lib64/xulrunner-sdk-1.9.2/bin -lxpcomglue -lSM -lICE   
libtool: link: g++ -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-unix-print-2.0 -I/usr/include/gtk-2.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/startup-notification-1.0 -I/usr/include/rarian -pthread -I/usr/include/libbeagle -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4 -DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4 -DXPCOM_GLUE -fshort-wchar -I/usr/include/xulrunner-sdk-1.9.2 -I/usr/include/nspr4 -fno-rtti -fshort-wchar -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -Wno-unused -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -o yelp yelp-Yelper.o yelp-yelp-base.o yelp-yelp-bookmarks.o yelp-yelp-debug.o yelp-yelp-error.o yelp-yelp-gecko-utils.o yelp-yelp-html.o yelp-yelp-io-channel.o yelp-yelp-settings.o yelp-yelp-utils.o yelp-yelp-window.o yelp-yelp-marshal.o yelp-yelp-main.o yelp-yelp-print.o yelp-yelp-page.o yelp-yelp-transform.o yelp-yelp-gecko-services.o yelp-yelp-document.o yelp-yelp-toc.o yelp-yelp-docbook.o yelp-yelp-db-print.o yelp-yelp-mallard.o yelp-yelp-man-parser.o yelp-yelp-man.o yelp-yelp-info.o yelp-yelp-info-parser.o yelp-gtkentryaction.o yelp-yelp-search.o yelp-yelp-search-parser.o yelp-eggdesktopfile.o yelp-eggsmclient.o yelp-eggsmclient-xsmp.o -pthread -pthread -Wl,-O1,--as-needed  -L/lib64 -lgconf-2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgmodule-2.0 -lexslt -lxslt -lm -lgcrypt -lgpg-error -lstartup-notification-1 -ldbus-glib-1 -ldbus-1 -lrarian -lbeagle -lxml2 -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lz -lbz2 -lX11 -L/usr/lib64/xulrunner-sdk-1.9.2/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl -L/usr/lib64/xulrunner-sdk-1.9.2/bin -lxpcomglue -lSM -lICE -pthread
/usr/bin/ld: /usr/lib64/xulrunner-sdk-1.9.2/lib/libxpcomglue.a(nsGlueLinkingDlopen.o): undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/bin/ld: note: 'dlclose@@GLIBC_2.2.5' is defined in DSO /usr/lib/gcc/x86_64-redhat-linux/4.4.3/../../../../lib64/libdl.so so try adding it to the linker command line
/usr/lib/gcc/x86_64-redhat-linux/4.4.3/../../../../lib64/libdl.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

which looks like libxpcomglue.a ought to be linked against -ldl

full logs: http://koji.fedoraproject.org/koji/getfile?taskID=2006160&name=build.log
Comment 1 Thomas Spura 2010-03-10 18:00:57 EST
(In reply to comment #0)
> which looks like libxpcomglue.a ought to be linked against -ldl

Furthermore xulrunner is violating the guidelines:
https://fedoraproject.org/wiki/Packaging/Guidelines#Packaging_Static_Libraries_2

"Static libraries and shared libraries. In this case, the static libraries must be placed in a *-static subpackage. Separating the static libraries from the other development files in *-devel allow us to track this usage by checking which packages BuildRequire  the *-static package. The intent is that whenever possible, packages will move away from using these static libraries, to the shared libraries."

There is no static subpackage, yet...


$ repoquery -l xulrunner-devel | grep sdk/lib
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libembed_base_s.a
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libembed_base_standalone.a
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libmozjs.so
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libmozreg_s.a
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libunicharutil_external_s.a
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libxpcom.so
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libxpcomglue.a
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libxpcomglue_s.a
/usr/lib/xulrunner-sdk-1.9.2/sdk/lib/libxul.so
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libembed_base_s.a
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libembed_base_standalone.a
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libmozjs.so
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libmozreg_s.a
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libunicharutil_external_s.a
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libxpcom.so
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libxpcomglue.a
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libxpcomglue_s.a
/usr/lib64/xulrunner-sdk-1.9.2/sdk/lib/libxul.so
Comment 2 Bug Zapper 2010-07-30 06:53:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Thomas Spura 2011-12-04 10:31:00 EST
(In reply to comment #2)
> This bug appears to have been reported against 'rawhide' during the Fedora 14
> development cycle.
> Changing version to '14'.
> 
> More information and reason for this action is here:
> http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Still applicable in current F16.

Do you plan to fix this?
Comment 4 Martin Stransky 2012-02-13 10:37:17 EST
(In reply to comment #3)
> Still applicable in current F16.
> 
> Do you plan to fix this?

Do you mean the static subpackage or unresolved symbols? If you're talking about the subpackage, please file a separate bug for it.
Comment 5 Martin Stransky 2012-12-21 08:57:18 EST
Should be fixed. If not please reopen and attach build log.

Note You need to log in before you can comment on or make changes to this bug.