Bug 56741 - With > 12 devices in RAID array, devices silently "disappear"
Summary: With > 12 devices in RAID array, devices silently "disappear"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2001-11-26 18:47 UTC by Michal Jaegermann
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-11-26 18:47:23 UTC
Description of Problem:

Apparently there is a limit of 12 devices in a RAID array.  At least
in a default configuration.  When presented with more Disk Druid
does not warn that it cannot accept all of them but silently drops
"excessive" ones in a seemingly "random" manner.  Results are a bit
surprising as, for example, disk "sde" may be quietly missing from
a resulting array while those with "higher" and "lower" letters are
present.

Comment 1 Jeremy Katz 2002-04-05 06:21:42 UTC
I just created a RAID array with 14 devices in it without any problems.  Is this
reproducible?

Comment 2 Michal Jaegermann 2002-04-05 16:52:33 UTC
> Is this reproducible.
It was at the time I filed that error.  An underlying cause was really
a 12 devices limit built in in raidtools.  Once I recompiled raidtools
with headers coordinated with kernels (which gives an upper limit of something
like 27 or 29 devices - IIRC) we did create arrays with bigger sets of disk
although I am not sure if anybody tried that with anaconda.  Probably
'raidtools' on "stage2" image have to be replaced for that.

Comment 3 Jeremy Katz 2002-04-08 20:34:47 UTC
Aha, that makes sense.  I seem to remember a discussion about that, even. 
Should be good for the next release then.

Comment 4 Red Hat Bugzilla 2006-02-21 18:48:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.