Bug 567432 - gdm should not require hal anymore
Summary: gdm should not require hal anymore
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-22 23:28 UTC by Michal Schmidt
Modified: 2015-01-14 23:24 UTC (History)
5 users (show)

Fixed In Version: gdm-2.29.92-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-17 16:07:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Schmidt 2010-02-22 23:28:33 UTC
Description of problem:
gdm 2.29.6 already contains the patch "remove remaining traces of Hal"
(http://git.gnome.org/browse/gdm/commit/?id=bbad0645c8dc70a57db415e02f838769a21a6539)

gdm-2.29.6-1.fc13 still Requires hal though.

Version-Release number of selected component (if applicable):
gdm-2.29.6-1.fc13

How reproducible:
always

Steps to Reproduce:
Try 'yum remove hal' in F-13.
  
Actual results:
yum wants to remove gdm too.

Expected results:
gdm should work fine without hal.

Comment 1 Stéphane Démurget 2010-04-17 10:08:19 UTC
I've got gdm-2.29.92-6.fc13.i686 installed and there does not seem to be any dep on hal anymore.

Comment 2 Stéphane Démurget 2010-04-17 10:12:54 UTC
(I mean, a direct dep :p)

Comment 3 Michal Schmidt 2010-04-17 16:07:39 UTC
Yes, the direct dependency on hal was removed in gdm-2.29.92-4.fc13.

That hal is still required by gnome-power-manager and by pm-utils are different bugs.


Note You need to log in before you can comment on or make changes to this bug.