Bug 56754 - Can't print to HP OfficeJet K60xi via USB
Can't print to HP OfficeJet K60xi via USB
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-26 18:48 EST by Tuan Hoang
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 04:55:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuan Hoang 2001-11-26 18:48:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
I cannot print to my HP OfficeJet K60xi via USB.  
The print job goes into the queue (viewed via lpq) and it just 
disappears.  The only warning is that it couldn't set the page 
width's to 2550 and is defaulting to 2400.

My system is up2date as of 2001-11-26 and I have the hpijs-0.97-1 
installed.  I've rebuilt the printconf-backend files and even 
restarted lpd, printer and PC.  My PC is an AMD Athlon 1GHz (200MHz 
FSB) on an ASUS A7V133 rev 1.04 and BIOS 1007.  All the hardware 
is working since I am able to print under Win2k SP2.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot PC with printer previously configured.
2. service lpd stop
3. rm -rf /var/cache/foomatic/compiled/*
   rm -rf /var/cache/foomatic/pcache/*
4. /usr/sbin/printconf-backend  --force-rebuild
5. Configure printer for HP OfficeJet K60 via printtool.
6. Restart lpd.
7. Test print postscript, text or image.



Actual Results:  Job gets into the printer queue and disappears but no
print out.

megatron:/home/tuan>lpq
Printer: lp@megatron
 Queue: 1 printable job
 Server: pid 2127 active
 Unspooler: pid 2128 active
 Status: IF filter 'mf_wrapper' filter msg - 'unable to set outwidth=2550,
default to page width=2400' at 18:20:03.047
 Rank   Owner/ID                  Class Job Files                 Size Time
1      tuan@megatron+126            A   126 OSPF_BGP_Links.txt     268 18:20:02



Expected Results:  It should have printed.

Additional info:

Omni-0.5.0-4
Omni-foomatic-0.5.0-4
foomatic-1.1-0.20011018.6
ghostscript-fonts-5.50-3
ghostscript-6.51-16
hpijs-0.97-1
kernel-2.4.9-13  (Athlon UP)
printconf-0.3.52-1
printconf-gui-0.3.52-1
Comment 1 Tim Waugh 2002-02-01 09:02:56 EST
This printer requires the hpijs driver, which we have not yet shipped.  It will
be in the next release however.

(There _should_ have been a warning message that popped up when you configured the
printer, I think.)

Note You need to log in before you can comment on or make changes to this bug.