Bug 56769 - Bad: dead keys at the us_intl are not working
Summary: Bad: dead keys at the us_intl are not working
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-27 12:19 UTC by Ulisses Penna
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 12:59:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulisses Penna 2001-11-27 12:19:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
Good: At the instalation, the area used to test the keybord works fine.
Even the dead keys work (a-tilde, c-cedilla, and so on)
Bad: After the installation, at the normal operation, the dead keys do not
work at all. I'm using the KDE interface. If I choose US-with_dead_keys,
the key "quotedbl" (shifted or not) prints a question mark. All other keys
work fine, but no dead keys!!!


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enter KDE Control Center
2.Choose Peripherals -> keyboard
3.Choose the "U.S. English w/ deadkeys" at the "Primary Layout" option
4. Click Apply
5. Hit the "apostrophe" or the "quotedbl" key and you will see a question
mark for both
6. Try the "tilde" key and you will see it's not "deadtilde" and so on
	

Actual Results:  The keys are not "dead". They appear as they are hit

Expected Results:  Latin characters (a-tilde, c-cedilla, a-grave, and so on)

Additional info:

Comment 1 Alexandre Oliva 2001-11-28 20:21:40 UTC
What I've been using to get dead keys on a us keyboard is a us_intl-based
configuration, that required a small patch to XFree86.  I run:

setxkbmap us -symbols 'us(pc104compose)+us_intl(basic)+group(ctrl_shift_toggle)'

and then, Left-Control+Right-Shift or Right-Control+Left-Shift can be used to
switch between enabled or disabled dead keys.  Note that this is mostly us_intl,
not plain us.

The patch I installed in my box was already submitted to the maintainers of
XFree86. It was necessary for the dead-keys-disabled configuration to make it
possible for one to enter `6' (the existing cfg gets an `^' for the 6 key
regardless of shift:

--- /usr/X11R6/lib/X11/xkb/symbols/us_intl~	Thu Sep  6 01:25:07 2001
+++ /usr/X11R6/lib/X11/xkb/symbols/us_intl	Thu Nov 15 17:22:26 2001
@@ -13,8 +13,8 @@
     // Alphanumeric section
     key <TLDE> {	[ dead_grave,	dead_tilde	],
 
		[      grave,	asciitilde	]	};
-    key <AE06> {	[	  6,	dead_circumflex	],
-
		[ asciicircum,
asciicircum
]
};
+    key <AE06> {	[	   6,	dead_circumflex	],
+
		[          6,	asciicircum	]	};
     key <AC11> {	[ dead_acute,	dead_diaeresis	],
 
		[ apostrophe,
quotedbl
]
};
 


Comment 2 Ulisses Penna 2001-11-28 22:05:26 UTC
GOD: OK! I applied the patch and I can toggle between the us and us_intl.
BAD: The dead_keys still are not "dead". Even /usr/X11R6/bin/xev tell me they
are dead_tilde, dead_grave and so on, I still can't get the latin characters
a-tilde, a-grave and so on at the screen. I'm using an Acer TravelMate 610TXVi
notebook for your information. I also tried some LC* variables but I'm not sure
which ones to use (I'm in Brazil) and which value they should have set.

Comment 3 Mike A. Harris 2002-05-30 08:13:47 UTC
I believe this to be fixed in 4.2.0-50.11 in rawhide.  Please test, and
report back if it works correctly.

Comment 4 Mike A. Harris 2003-05-21 12:59:13 UTC
Bug has been in MODIFIED state for almost a year awaiting testing feedback.
I'm assuming that no feedback, is good feedback, and that the problem was
indeed fixed.  ;o)

Closing as CURRENTRELEASE of Red Hat Linux 9


Note You need to log in before you can comment on or make changes to this bug.