Bug 56772 - swap partition format crashes
swap partition format crashes
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-27 08:46 EST by Gena Hahn
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-08 13:07:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
bug report generated by anaconda (979 bytes, text/plain)
2001-11-27 08:48 EST, Gena Hahn
no flags Details

  None (edit)
Description Gena Hahn 2001-11-27 08:46:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Druid insists on formatting swap partition (already formatted) and stops 
with a bug. see report.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.installation: custom,...choose mount points for existing Linux and fat32 
partitions, choos NOT to format the partitions (swap is NOT on the list), 
hit next
2. message "formatting swap partition" (or some such) is soon followed by
3. An exceptional condition has occurred, This is most likely a bug.....

Actual Results:  all stops, I have the traceback on the screen

Expected Results:  swap should have been formatted and linux install (as 
it happened with 6.0 - I am reinstalling the works)

Additional info:

Pentium II @500MHz, 512 RAM, 2HD of 16GB each.
boot on disk 1 (beginning), / and /usr on disk 2 (beginning), swap 
(1027mb) on disk 2 (end)
all partitions prepared with Partition Magic 7.0
Windows XP nstalled on disk 1 in the partition next after /boot Fat32).
several othe data partions on both disks (fat32)
Comment 1 Gena Hahn 2001-11-27 08:48:10 EST
Created attachment 38745 [details]
bug report generated by anaconda
Comment 2 Gena Hahn 2001-11-27 11:10:57 EST
After a few hours of testing (sigh) I have come to the conclusion that the 
problem is neither the formatting of the swap partition, nor druid, but 
something entirely different. My (nonexhaustive if exhausting) test show that 
all is well if I DON"T choose to select individual packages. So choosing 
CUSTOM, picking the global areas (graphics, emacs, games, whatever, for 
installation of even things I don't want, and not installing some things I do 
want) without furher selecting will lead to an installation without problems.

It is a workaround, if not pleasant.

Comment 3 Brent Fox 2001-12-03 20:41:51 EST
Hmm...selecting or not selecting individual packages shouldn't have any effect
on the crash you are seeing.  I'm curious what would happen if you just skipped
adding a mount point for the DOS partition during ths install.  That seems to be
where the problem is coming from.

Now that you have the install finished, do you want to continue investigating
this issue or do you want to leave it alone?

Comment 4 Gena Hahn 2001-12-04 07:11:33 EST
1. I lied, it is not i386 but i686
2. yes i want it investigated, see below
3. the workaround is not perfect. maybe my memory is bad, but I recall having a 
tool in a previous incarantion whereby I could both install and remove 
packages. the kpackages I used only adds things.
4. windows xp seems unhappy with LILO in boot sector, so I had to reinstall the 
works and, as a precaution, I removed LInux as well. so I'll have to reinstall 
(maybe I'll use BootMagic instead of LILO). It would be good if the thing 
worked (would linux 7.2 package help?)
5. In none of the tests did I put a mountpoint for the windows XP partition.
Detaisl: I have 2 disks, partitioned as follws:
A: small boot partition for linux, windows xp programs partition, documenst 
partition, data partition, misc partition and windows swap partition
B: linux root, linux usr, then specific purpose partitions (photo, music, 
divers, temp) and linux swap.
all get mountpoints except the xp nd the windows swap.
all non-linux are FAT32.

Comment 5 Brent Fox 2001-12-08 12:45:59 EST
Win XP shouldn't care about having LILO in the boot sector.  That shouldn't
matter at all.  Having said that, I haven't tested dual booting XP and 7.0.  I
have tested dual booting with XP and 7.2, but 7.2 uses GRUB as the default
bootloader instead of LILO.  But my guess is that XP shouldn't care about what
bootloader is being used.  I would expect it to work with LILO, GRUB, BootMagic,
or whatever.

Do you have the ability to download 7.2 and give it a try?
Comment 6 Gena Hahn 2001-12-08 13:07:49 EST
Agreed, XP should not care. I have no idea what happened.
Maybe I'll get 7.2 and try (I'll have to get the CD's, being on a modem 
connection would make it too long and too expensive as I am at the moment in 
Prague where one pays for connections).

What surprised me is that that anaconda should care whether I do or do not 
choose individual componets. yet that seems to be the only variable (and I have 
to admit that since one reason for running linux is the lack of need for 
reinstalls, I am not exactly willing to tun hours of tests. after all this was 
to be a quickie afternoon...two weeks ago. as the man said: things always go 
wrong at the worst possible moment).

I'll report later - january - on progress.
Comment 7 Brent Fox 2002-01-20 23:58:29 EST
There is an Errata available that fixes this problem.  It is available at: 

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.