Bug 567754 - tolua++ don't compile with --enable-lua-cairo option in conky
Summary: tolua++ don't compile with --enable-lua-cairo option in conky
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tolua++
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Niemueller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 567631 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-23 20:28 UTC by dominique
Modified: 2010-04-14 14:09 UTC (History)
2 users (show)

Fixed In Version: tolua++-1.0.93-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-25 22:31:15 UTC
Type: ---


Attachments (Terms of Use)

Description dominique 2010-02-23 20:28:25 UTC
Description of problem:
I use conky, and for test I want to compile it with --enable-lua-cairo option.
But i have this error with make:
make[2]: entrant dans le répertoire «
/home/dominique/Téléchargement/conky-1.8.0~git925e80ac/lua »
/bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I.
-I../src -I/usr/include/cairo -I/usr/include/pixman-1
-I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/cairo
-I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12
-MT libcairo_la-libcairo.lo -MD -MP -MF .deps/libcairo_la-libcairo.Tpo -c
-o libcairo_la-libcairo.lo `test -f 'libcairo.c' || echo './'`libcairo.c
libtool: compile: gcc -DHAVE_CONFIG_H -I. -I../src -I/usr/include/cairo
-I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12
-I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2
-I/usr/include/libpng12 -MT libcairo_la-libcairo.lo -MD -MP -MF
.deps/libcairo_la-libcairo.Tpo -c libcairo.c -fPIC -DPIC -o
.libs/libcairo_la-libcairo.o
libcairo.c: In function ‘tolua_cairo_cairo_matrix_t_create00’:
libcairo.c:291: erreur: ‘tolua_outside’ undeclared (first use in this
function)
libcairo.c:291: erreur: (Each undeclared identifier is reported only once
libcairo.c:291: erreur: for each function it appears in.)
libcairo.c:291: erreur: expected ‘;’ before ‘cairo_matrix_t’
libcairo.c:292: erreur: ‘tolua_ret’ undeclared (first use in this
function)
libcairo.c: In function ‘tolua_cairo_cairo_text_extents_t_create00’:
libcairo.c:3550: erreur: ‘tolua_outside’ undeclared (first use in this
function)
libcairo.c:3550: erreur: expected ‘;’ before
‘cairo_text_extents_t’
libcairo.c:3551: erreur: ‘tolua_ret’ undeclared (first use in this
function)
libcairo.c: In function ‘tolua_cairo_cairo_font_extents_t_create00’:
libcairo.c:3728: erreur: ‘tolua_outside’ undeclared (first use in this
function)
libcairo.c:3728: erreur: expected ‘;’ before
‘cairo_font_extents_t’
libcairo.c:3729: erreur: ‘tolua_ret’ undeclared (first use in this
function)
make[2]: *** [libcairo_la-libcairo.lo] Erreur 1
make[2]: quittant le répertoire «
/home/dominique/Téléchargement/conky-1.8.0~git925e80ac/lua »
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire «
/home/dominique/Téléchargement/conky-1.8.0~git925e80ac/lua »
make: *** [all-recursive] Erreur 1

I post a report on bugzilla of conky (http://sourceforge.net/tracker/?func=detail&atid=757309&aid=2955967&group_id=143975) and it appear that the tolua++ version of Fedora is not good.(require 5.1 version and the fedora is 1.0.92)
Can you update the fedora package?

Comment 1 Tim Niemueller 2010-02-23 22:18:24 UTC
Works for me with conky 1.7.2 (just downloaded and tried). tolua++ 1.0.92 is the latest stable release (1.0.93 doesn't work properly for me). There is no version 5.1. It's probably a misunderstanding, tolua++ links against Lua 5.1 and its soname is tolua++-5.1.so.

Please try with 1.7.2, if that works it's an upstream problem. If that doesn't we have to find out why it does on my machine and not on yours.

Comment 2 dominique 2010-02-24 06:39:41 UTC
Thank for your help.
I try compiling with conky 1.7.2 and that work.
But I want use conky-1.8.0~git925e80ac, here: https://launchpad.net/ubuntu/lucid/+source/conky/1.8.0~git925e80ac-0ubuntu1/+files/conky_1.8.0~git925e80ac.orig.tar.bz2 , because with this version there is the real transparency, and that is very useful with Kde.
And with this version, conky don't compile with --enable-lua-cairo option...
Anyway I wait for the stable version of conky 1.80 and look if that work.

Comment 3 Tim Niemueller 2010-02-24 09:06:38 UTC
Ok, please report this to the conky upstream so that they can fix their software. Closing this here for now.

Comment 4 dominique 2010-02-25 05:09:18 UTC
Hi...
I posted your comment to conky bugzilla.
Here the answer:
Since it works perfectly on debian, LFS, gentoo and ubuntu, i'm pretty
sure that the problem is with the fedorapackage. You'll need to
contact the fedora-developer that maintains conky and tell him to fix
the bug.

I am not a programmer, but I think you should contact the conky developer and see with him why there is this problem.

Comment 5 Tim Niemueller 2010-02-25 23:44:19 UTC
I have had a look and they are using tolua++ 1.0.93, while we ship 1.0.92 in Fedora currently. I will issue an update later on that fixes this. The Conky developers should have been able to tell you that...

Comment 6 dominique 2010-02-26 17:16:30 UTC
For test I download the tolua++ 1.0.93 source and try compile it with scons.
But I have error:

[dominique@localhost tolua++-1.0.93]$ scons
scons: Reading SConscript files ...

scons: warning: The Options class is deprecated; use the Variables class instead.
File "/home/dominique/Téléchargement/tolua++-1.0.93/SConstruct", line 19, in <module>
('********* tolua is ', 'bin/tolua++_bootstrap')

scons: warning: The env.Copy() method is deprecated; use the env.Clone() method instead.
File "/home/dominique/Téléchargement/tolua++-1.0.93/src/tests/SCsub", line 2, in <module>
scons: done reading SConscript files.
scons: Building targets ...
gcc -o src/bin/tolua.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/bin/tolua.c
gcc -o src/bin/toluabind_default.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/bin/toluabind_default.c
gcc -o src/lib/tolua_event.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/lib/tolua_event.c
gcc -o src/lib/tolua_is.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/lib/tolua_is.c
gcc -o src/lib/tolua_map.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/lib/tolua_map.c
src/lib/tolua_map.c: In function 'tolua_usertype':
src/lib/tolua_map.c:398: warning: passing argument 2 of 'tolua_newmetatable' discards qualifiers from pointer target type
src/lib/tolua_map.c:28: note: expected 'char *' but argument is of type 'const char *'
src/lib/tolua_map.c: In function 'tolua_dobuffer':
src/lib/tolua_map.c:699: warning: value computed is not used
gcc -o src/lib/tolua_push.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/lib/tolua_push.c
gcc -o src/lib/tolua_to.o -c -I/usr/include/lua50 -O2 -ansi -Wall -Iinclude src/lib/tolua_to.c
ar rc lib/libtolua++_static.a src/lib/tolua_event.o src/lib/tolua_is.o src/lib/tolua_map.o src/lib/tolua_push.o src/lib/tolua_to.o
ranlib lib/libtolua++_static.a
gcc -o bin/tolua++_bootstrap src/bin/tolua.o src/bin/toluabind_default.o lib/libtolua++_static.a -Llib -llua50 -llualib50 -ldl -lm
/usr/bin/ld: cannot find -llua50
collect2: ld returned 1 exit status
scons: *** [bin/tolua++_bootstrap] Error 1
scons: building terminated because of errors.
[dominique@localhost tolua++-1.0.93]$ 

And when I want compile with the 5.1 option, I have this error:

[dominique@localhost tolua++-1.0.93]$ scons
scons: Reading SConscript files ...

scons: warning: The Options class is deprecated; use the Variables class instead.
File "/home/dominique/Téléchargement/tolua++-1.0.93/SConstruct", line 19, in <module>
('********* tolua is ', 'bin/tolua++5.1_bootstrap')

scons: warning: The env.Copy() method is deprecated; use the env.Clone() method instead.
File "/home/dominique/Téléchargement/tolua++-1.0.93/src/tests/SCsub", line 2, in <module>
scons: done reading SConscript files.
scons: Building targets ...
gcc -o src/bin/tolua.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/bin/tolua.c
gcc -o src/bin/toluabind_default.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/bin/toluabind_default.c
gcc -o src/lib/tolua_event.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/lib/tolua_event.c
gcc -o src/lib/tolua_is.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/lib/tolua_is.c
gcc -o src/lib/tolua_map.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/lib/tolua_map.c
src/lib/tolua_map.c: In function 'tolua_usertype':
src/lib/tolua_map.c:398: warning: passing argument 2 of 'tolua_newmetatable' discards qualifiers from pointer target type
src/lib/tolua_map.c:28: note: expected 'char *' but argument is of type 'const char *'
gcc -o src/lib/tolua_push.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/lib/tolua_push.c
gcc -o src/lib/tolua_to.o -c -I/usr/include/lua5.1 -O2 -ansi -Iinclude src/lib/tolua_to.c
ar rc lib/libtolua++5.1_static src/lib/tolua_event.o src/lib/tolua_is.o src/lib/tolua_map.o src/lib/tolua_push.o src/lib/tolua_to.o
ranlib lib/libtolua++5.1_static
gcc -o bin/tolua++5.1_bootstrap src/bin/tolua.o src/bin/toluabind_default.o lib/libtolua++5.1_static -Llib -llua5.1 -ldl -lm
/usr/bin/ld: cannot find -llua5.1
collect2: ld returned 1 exit status
scons: *** [bin/tolua++5.1_bootstrap] Error 1
scons: building terminated because of errors.
[dominique@localhost tolua++-1.0.93]$

Comment 7 Tim Niemueller 2010-02-26 20:32:59 UTC
I have build 1.0.93 just fine, needs an updated patch. I'll push an update as soon as I find some minutes. Just be patient.

Comment 8 Fedora Update System 2010-02-27 21:40:09 UTC
tolua++-1.0.93-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tolua++-1.0.93-1.fc12

Comment 9 dominique 2010-02-28 06:10:59 UTC
Hi...
I install tolua++-1.0.93-1.fc12 from koji, and now --enable-lua-cairo option work fine.
Thank you.

Comment 10 Tim Niemueller 2010-02-28 09:46:39 UTC
Please also report this to the Update URL given in Comment 8. Thank you.

Comment 11 dominique 2010-02-28 11:55:27 UTC
To Tim Niemueller
Done...

Comment 12 Fedora Update System 2010-03-02 01:01:17 UTC
tolua++-1.0.93-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tolua++'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3260

Comment 13 Fedora Update System 2010-03-25 22:31:10 UTC
tolua++-1.0.93-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Miroslav Lichvar 2010-04-14 14:09:55 UTC
*** Bug 567631 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.