Bug 56777 - Power management turns off daytime clock!
Power management turns off daytime clock!
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-27 09:36 EST by dsamperi
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:54:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsamperi 2001-11-27 09:36:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Bad: power management support turns off the daytime clock. Did not
happen with RH 7.1 (just upgraded). Machine is the Toshiba 8000M
desktop, Intel Pentium III, 1GHz, 512MB RAM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 7.2
2.Don't touch machine all night
3.
	

Actual Results:  In the morning (9AM) the machine shows 4AM (approx). When
I run
netdate to update the clock my screen blanks momentarily. BTW, I
see the same kind of screen blanking twice during the
boot sequence (during those messages [OK]...). NOTE: while the clock
seems to be turned off, my modem is not, because my ISP connection is
still active in the morning.

Expected Results:  Machine should keep the correct time.

Additional info:
Comment 1 dsamperi 2001-11-30 21:46:44 EST
Correction to my submission: Looks like Red Hat 7.2 out of the box does not
suffer from this problem because I just tested booting with the original
kernel. This leads naturally to a question that I submitted to Red Hat (as
a registered user) but never received a response to. Namely, where do I find
the exact kernel configuration that was used to build the kernel that is
shipped with Red Hat 7.2? I used the srpm that is on the CD but it does not seem
to be ready to compile with the particular configuration used by Red Hat. If
I can find this configuration then I can figure our what kernel config option
is causing this clock problem.
Comment 2 Arjan van de Ven 2001-12-02 12:15:25 EST
The easiest way to get to the config file is to install the kernel-source rpm;
if you have done that the config files (there's more than one, eg one for smp
etc) in /usr/src/linux-2.4/configs ...........
Comment 3 dsamperi 2001-12-03 00:59:43 EST
I already installed the kernel source RPM yet I cannot find the source tree
and configuration used by Red Hat to build Version 7.2. All I find are a bunch
of empty directories with names like i386, i686, etc., and some patch files. I
am looking under /usr/src/...

I tried building a kernel using the latest 2.4.16 source, and there was a
promising lead: the char device with major/minor 10/183 could not be found at
boot time. Turns out this is the real-time clock, and when I enabled RTC in
the configuration this boot error message went away. Unfortunately, this did
not fix the clock problem. It is now 12AM, yet the clock on my PC shows 3PM
after sitting idle all day.
It would be helpful if I can find the source tree and configs used by Red Hat.

Dominick
Comment 4 Arjan van de Ven 2001-12-03 04:01:33 EST
You are probably talking about the kernel-2.4.X-Y.src.rpm; there also is a
kernel-source-2.4.X-Y.i386.rpm ! that one puts the full source in
/usr/src/linux-2.4 and the configs in the configs subdirectory of that
Comment 5 dsamperi 2001-12-03 23:47:51 EST
I tried the original Red Hat 7.2 kernel again. I let it run all day today, and
again my clock is behind (by 2 hours), so finding the kernel source is not
going to help. My PC keeps the right time only when I run Windows!

To reset the time I run netdate, and when I do this my screen blanks (seems
to go into sleep mode). I have to hit a key to wake it up, and at that point
the time has been correctly set by netdate. Another strange behavior when I
run the original kernel is that my PPP dialup connection is always dropped
after a while, yet it stays up when I run kernel 2.4.16! (It stays up
because I use 'lcp-echo-interval 60' in my /etc/ppp/options file, but this
does not seem to have any effect when I run the RH 7.2 kernel!)

Any ideas?
Comment 6 dsamperi 2001-12-15 09:46:00 EST
I have the resolution, but I would not call this "NOTABUG". The man page for
hwclock explains that there are two clocks, the CMOS (or hardware) clock and
the software (interrupt driven) clock maintained by Linux (initialized from
the hardware clock at boot time). The problems described above were caused by
the fact that in my BIOS I had "SUSPEND AFTER 20 MINS" turned on. This does not
cause any problems for Windows 2000, but it does for Linux. Looks like when
the machine goes into SUSPEND mode the Linux clock runs slow (or stops?).

Note that the hardware clock itself does not run slow, and the Linux software
clock can be fixed with /sbin/hwclock --hctosys. Running this command when the
clock is slow will put the monitor to sleep because it thinks it has been idle
for a long time.
The work-around is to turn off SUSPEND mode completely in the BIOS.

Note You need to log in before you can comment on or make changes to this bug.