Bug 567840 - LVMError: lvdeactivate failed for lv_swap: LV VolGroup/lv_swap in use: not deactivating
LVMError: lvdeactivate failed for lv_swap: LV VolGroup/lv_swap in use: not de...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:2cefada975d5bf88d...
: Triaged
: 562335 566645 567976 (view as bug list)
Depends On:
Blocks: F13Alpha/F13AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-02-23 23:29 EST by Jens Petersen
Modified: 2010-03-09 18:29 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.32-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 20:13:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (113.75 KB, text/plain)
2010-02-23 23:29 EST, Jens Petersen
no flags Details
Attached traceback automatically from anaconda. (144.91 KB, text/plain)
2010-02-24 18:31 EST, Adam Williamson
no flags Details

  None (edit)
Description Jens Petersen 2010-02-23 23:29:25 EST
The following was filed automatically by anaconda:
anaconda 13.27 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 418, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 2286, in teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/__init__.py", line 2009, in umountFilesystems
    device.teardown()
  File "/usr/lib/anaconda/storage/__init__.py", line 1139, in umountFilesystems
    self.fsset.umountFilesystems(ignoreErrors=ignoreErrors, swapoff=swapoff)
  File "/usr/lib/anaconda/livecd.py", line 174, in doPreInstall
    anaconda.storage.umountFilesystems(swapoff = False)
  File "/usr/lib/anaconda/backend.py", line 294, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1334, in handleRenderCallback
    self.currentWindow.renderCallback()
LVMError: lvdeactivate failed for lv_swap: LV VolGroup/lv_swap in use: not deactivating
Comment 1 Jens Petersen 2010-02-23 23:29:31 EST
Created attachment 395896 [details]
Attached traceback automatically from anaconda.
Comment 2 Andy Lindeberg 2010-02-24 09:29:26 EST
*** Bug 567976 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2010-02-24 18:31:16 EST
Created attachment 396183 [details]
Attached traceback automatically from anaconda.
Comment 4 Adam Williamson 2010-02-24 18:33:44 EST
I hit this attempting to do an install of a F13 alpha RC3 live build - anaconda 13.31. This is with a 'delete existing Linux partitions' install into a KVM (using virt-manager). The disk image had been used for a previous failed attempt at installing, I don't know offhand what state it was in. Will re-test with a clean disk image and see what happens.
Comment 5 Adam Williamson 2010-02-24 18:41:37 EST
Same failure with a brand new, never-used-for-anything disk image, doing a next-next-next install. Looks like a blocker to me...
Comment 6 Adam Williamson 2010-02-24 18:46:09 EST
I notice this in dmesg:

Adding 983032k swap on /dev/mapper/vg testbed-lv_swap.  Priority:-1 extents:1 across:983032k

is the system *using* the swap area that was created by anaconda and hence causing anaconda to barf?
Comment 7 Fedora Update System 2010-02-25 16:42:03 EST
anaconda-13.32-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.32-1.fc13
Comment 8 Fedora Update System 2010-02-26 06:50:54 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2985
Comment 9 Nathanael Noblet 2010-02-26 13:49:55 EST
Using the latest DVD installer image (as of an hour ago) I can install successfully.
Comment 10 Adam Williamson 2010-02-26 20:13:35 EST
Yes, this is fixed in RC4. Confirmed here.
Comment 11 Fedora Update System 2010-02-27 07:58:07 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-02-28 09:45:59 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-02-28 20:40:32 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-03-01 19:59:37 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-03-02 20:59:31 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-03-03 03:17:18 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-03-03 19:22:22 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-03-03 20:32:52 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-03-04 22:32:29 EST
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 David Lehman 2010-03-09 18:29:26 EST
*** Bug 562335 has been marked as a duplicate of this bug. ***
Comment 21 David Lehman 2010-03-09 18:29:53 EST
*** Bug 566645 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.