Bug 56797 - Anaconda Displays an error and terminates the installation process when all packages are installed
Anaconda Displays an error and terminates the installation process when all p...
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-27 17:13 EST by Guillem
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-19 10:12:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The file is the core dump of the installation process (76.25 KB, patch)
2001-12-04 17:18 EST, Guillem
no flags Details | Diff

  None (edit)
Description Guillem 2001-11-27 17:13:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [ca] (Win95; U)

Description of problem:
I've tried to select diferent packages and the problem persists. I've tried in a P150 with 49 MB of RAM and with a PIII600 with 256 MB of 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Only start Installation

Actual Results:  Fatal crash and the system dosen't work anymore

Additional info:
Comment 1 Jeremy Katz 2001-11-28 15:56:18 EST
Does it crash and give you the opportunity to save the traceback to a floppy? 
If so, could you attach this traceback?
Comment 2 Guillem 2001-12-04 17:18:21 EST
Created attachment 39627 [details]
The file is the core dump of the installation process
Comment 3 Brent Fox 2001-12-18 11:56:46 EST
Can you try booting with 'linux ide=nodma'?  Does that help?
Comment 4 Guillem 2001-12-19 10:12:02 EST
All drives attached in my computer are DMA access capable.That does'nt work!!
(The Computer is an Intel Pentium III 600 MHz with 256 MB of RAM. With a 40 GB 
Hard Disk, and a Sony DVD.)
Comment 5 Brent Fox 2002-01-20 23:53:34 EST
Oh, I see what the problem is.  From looking far down in the traceback, I see
the following message:

Instalacisn de shadow-utils.
unpacking of archive failed on file /etc/login.defs;3bffa710: cpio: MD5 sum mismatch

This means that the installation of shadow-utils failed.  This package contains
the /usr/sbin/usermod command, so when anaconda runs usermod in the post-install
script, the program crashes because it can't find the command.  I think that you
have a bad cd since it appears that the shadow-utils RPM is corrupt on the cd. 
Please reopen if you see this behavior with different cdroms.

Note You need to log in before you can comment on or make changes to this bug.