Bug 567990 - SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on /root/.xsession-errors.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "read append" access ...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:fe639f15e78...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-24 14:53 UTC by John Antony
Modified: 2010-02-24 16:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-24 16:44:12 UTC


Attachments (Terms of Use)

Description John Antony 2010-02-24 14:53:47 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on
/root/.xsession-errors.

Detailed Description:

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root/.xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.29.6-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.9-1.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33-0.48.rc8.git1.fc14.i686 #1 SMP
                              Fri Feb 19 04:03:01 UTC 2010 i686 i686
Alert Count                   43
First Seen                    Sun 03 Jan 2010 09:57:27 PM IST
Last Seen                     Wed 24 Feb 2010 08:02:51 PM IST
Local ID                      ed334c1a-ed92-4dca-bb33-bd8d642845c7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1267021971.282:19): avc:  denied  { read append } for  pid=5675 comm="gdm-session-wor" name=".xsession-errors" dev=sda5 ino=63 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1267021971.282:19): arch=40000003 syscall=5 success=no exit=-13 a0=8196ab0 a1=442 a2=180 a3=8196ab0 items=0 ppid=2304 pid=5675 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,admin_home_t,file,read,append
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file { read append };

Comment 1 Daniel Walsh 2010-02-24 16:44:12 UTC

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.