Bug 56802 - freetype (2.0.3) is build without the TTF bytecode interpreter, but freetype 1.4 in the same package is.
freetype (2.0.3) is build without the TTF bytecode interpreter, but freetype ...
Status: CLOSED DUPLICATE of bug 56646
Product: Red Hat Linux
Classification: Retired
Component: freetype (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-27 18:29 EST by ben.de.rydt
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 03:47:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ben.de.rydt 2001-11-27 18:29:50 EST
Description of Problem:

Since release 2.0.3, the TTF bytecode interpreter is no longer selected 
by default in freetype, due to possible legal problems (patent issues).
However, the freetype 1.4 package, contained in the freetype-2.0.3-7 rpm 
does contain the bytecode interpreter.

For the user, this is unfortunate: the output of freetype without the 
bytecode interpreter is horrible at its best and plain unreadable at 
small fontsizes at its worst. For RedHat this is unfortunate because 
there may be a possible legal problem.

In the default RedHat 7.2 configuration, TTF-fonts are more usable 
without antialiasing than with, i.e. by using the bytecode interpreter is 
xfs than using the Xft-library without the interpreter.
Comment 1 Mike A. Harris 2002-01-18 03:47:28 EST
I agree completely with you.  I have brought this issue up with our
legal department, and decision makers, and hopefully will have a
definitive answer on this issue soon.  2.0.6 is in rawhide now.
Comment 2 Mike A. Harris 2002-01-23 14:48:35 EST

*** This bug has been marked as a duplicate of 56646 ***

Note You need to log in before you can comment on or make changes to this bug.