Bug 56804 - rpm.rpmsave backup directory created by installer
rpm.rpmsave backup directory created by installer
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2001-11-27 18:56 EST by Chris Ricker
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 15:21:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-11-27 18:56:15 EST
Back in September, I upgraded a system from RH 7.1 to RH 7.2.  I was just
freeing up wasted space on the system, and discovered that the installer
apparently backed up the /var/lib/rpm directory to /var/lib/rpm.rpmsave,
wasting 20 megs on the system:

[root@hanuman lib]# ls -ld rpm*
drwxr-xr-x    2 root     root         1024 Nov 27 15:55 rpm
drwxr-xr-x    2 rpm      rpm          1024 Sep 16 21:02 rpm.rpmsave
[root@hanuman lib]# du -s rpm*
7975    rpm
12403   rpm.rpmsave
[root@hanuman lib]#
Comment 1 Michael Fulbright 2001-12-03 16:07:45 EST
I believe this is necessary because we want to backup the original database
before preforming a rebuild on it. Assigning bug to an engineer.
Comment 2 Chris Ricker 2001-12-03 18:45:14 EST
Well, I'll agree that the backup is necessary, but the installer should have
removed it afterwards....
Comment 3 Jeremy Katz 2002-04-04 15:36:08 EST
But we don't want to remove it after install.  There is no way for me to tell
that the new RPM database is actually valid and has correct information. 
Leaving the old one there gives you at least something to fall back to in the
case that there is a problem.

Note You need to log in before you can comment on or make changes to this bug.