Bug 568106 - Unable to enter grub menu in F-13-Alpha with console=ttyS0
Unable to enter grub menu in F-13-Alpha with console=ttyS0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-02-24 14:27 EST by James Laska
Modified: 2013-09-02 02:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.40-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 02:56:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2010-02-24 14:27:31 EST
Description of problem:

After a serial console install (virt), unable to access the grub menu to change boot args.

Version-Release number of selected component (if applicable):
 * grub-0.97-64.fc13.i686

How reproducible:
 * Everytime I try to enter grub after a virt console=ttyS0 install

Steps to Reproduce:
1. Install a system using "console=ttyS0 serial" (typical with virt).  
2. After install reboot, and attempt to hit a modified key to access the grub menu (as has been done in previous releases).
  
Actual results:

Guest installation complete... restarting guest.
Connected to domain vguest1
Escape character is ^]
Press any key to continue.
Press any key to continue.
Press any key to continue.

<press 'e' key>

The menu screen flashes and quickly continues booting

Expected results:

I should be able to access the grub menu to provide custom boot args if needed.

Additional info:

 * I've tried addition keys, including <space>, <enter>, <shift>, <esc> (note that modified keys don't work in serial console like they do when booting normally).

sh-4.1# cat /mnt/sysimage/boot/grub/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_test1115-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/vda
default=0
timeout=0
serial --unit=0 --speed=9600
terminal --timeout=5 serial console
title Fedora (2.6.33-0.51.rc8.git6.fc13.i686.PAE)
	root (hd0,0)
	kernel /vmlinuz-2.6.33-0.51.rc8.git6.fc13.i686.PAE ro root=/dev/mapper/vg_test1115-lv_root rd_LVM_LV=vg_test1115/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us console=ttyS0 rhgb quiet
	initrd /initramfs-2.6.33-0.51.rc8.git6.fc13.i686.PAE.img
Comment 1 He Rui 2010-03-02 01:23:05 EST
Reproduced after a f13-alpha-rc4 install by serial console.
Comment 2 James Laska 2010-03-23 16:19:02 EDT
= Steps to reproduce =

1. Initiate a virt-install using only the serial output

# virt-install --name AUTOQA --ram 768 --vcpus 1 --os-type linux --os-variant fedora13 --location http://dell-t5400.test.redhat.com/cblr/links/F-13-Beta-TC1-x86_64 --accelerate --nographics --disk path=/var/lib/libvirt/images/AUTOQA0.img,size=6,bus=ide  -x "serial console=ttyS0"

2. Proceed with install
3. After install and reboot, attempt to enter the grub menu
Comment 3 James Laska 2010-03-25 12:00:06 EDT
Reproduced on bare metal system.  So while virt may make it easier to reproduce the failure, the problem doesn't seem specific to the virt environment.

I add the following lines to /boot/grub/grub.conf
  serial --unit=0 --speed=9600
  terminal --timeout=5 serial console

And wait to see the prompt on the serial and physical consoles:
Press any key to continue.
Press any key to continue.
Press any key to continue.

 * FAIL - when prompted, press the <Up> or <Down> key on the serial console when offered the boot menu.  The system boots immediately and does not offer the grub menu over serial console.

 * PASS - when prompted, press the <Up> or <Down> key on the physical console.  The system correctly shows the grub menu and allows for editing the grub boot entries.
Comment 4 James Laska 2010-03-25 13:15:26 EDT
Confirmed with pjones (development) and jkeating (release engineering) that it is acceptable to move this issue to F13Blocker as it does not current block any Beta release criteria.
Comment 5 James Laska 2010-04-30 09:37:21 EDT
F-12 serial console installs set a grub.conf timeout=5
F-13 serial console installs set a grub.conf timeout=0

Thanks to bcl for the tip, that seems to be the trigger for the problem.
Comment 6 Adam Williamson 2010-04-30 13:55:29 EDT
This bug was discussed at the 2010/04/30 blocker review meeting.

It was agreed that this is not significant enough to be a release blocker, so we are dropping it to F13Target. However, since the fix is likely to be simple and non-invasive, we're happy to accept the fix if it's available in time (before Tuesday 2010/05/04).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Jesse Keating 2010-04-30 13:57:28 EDT
This may be a bug in grub itself that it doesn't honor the terminal timeout, but a patch was sent to work around this by defaulting the global grub timeout to 5 when serial is in play.
Comment 8 James Laska 2010-05-04 20:40:46 EDT
Confirmed fix using anaconda-13.39-1 + http://jlaska.fedorapeople.org/updates-568528.img

Safe to mark as VERIFIED/CLOSED once anaconda-13.40-1 is available
Comment 9 Fedora Update System 2010-05-05 01:16:39 EDT
anaconda-13.40-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 10 Fedora Update System 2010-05-05 03:23:11 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 11 Fedora Update System 2010-05-06 02:55:19 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.