Bug 568164 - RFE add udpu communication transport to avoid requirement for multicast
RFE add udpu communication transport to avoid requirement for multicast
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync (Show other bugs)
6.0
All Linux
high Severity low
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: FutureFeature, TechPreview
: 681269 (view as bug list)
Depends On:
Blocks: 655920 624558
  Show dependency treegraph
 
Reported: 2010-02-24 17:21 EST by Steven Dake
Modified: 2016-04-26 12:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: corosync-1.2.3-23.el6
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
example configuration file for those that configure udpu via corosync.conf (and not using the cman service engine) (1.06 KB, application/octet-stream)
2010-11-24 13:41 EST, Steven Dake
no flags Details
patch 1 to add udpu support (5.01 KB, patch)
2010-12-02 13:51 EST, Steven Dake
no flags Details | Diff
patch 2 to add udpu support (74.13 KB, patch)
2010-12-02 13:51 EST, Steven Dake
no flags Details | Diff
patch 3 for udpu support (3.34 KB, patch)
2010-12-02 13:52 EST, Steven Dake
no flags Details | Diff
patch 4 to add udpu support (2.30 KB, patch)
2010-12-02 13:52 EST, Steven Dake
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 37995 None None None Never

  None (edit)
Description Steven Dake 2010-02-24 17:21:55 EST
Description of problem:
Some customer environments are not capable of changing their network configuration to enable multicast.

Version-Release number of selected component (if applicable):
corosync-1.2.0-1.el6

Engineering has a concept for a transport called udpu.  Essentially udpu simulates multicast by using UDP unicast to communicate to all the potential cluster members in the system.  Because the replication of packets occurs in the OS rather then the hardware switch, the performance is slower.  Customers desiring plock usage from gfs2 will not be satisfied with the performance of the udpu transport.  MRG customers would also not be satisified.  However, in many use cases such as normal pacemaker operation and small scale clusters (8 nodes or less) that don't require MRG operation or plock operation, the performance should be acceptable.

udpu: uses only UDP unicast - available in all network environments - low performance
udp: uses UDP unicast and UDP multicast - requires network configuration - high performance
iba: uses IBA multicast - IBA switches support multicast in a standard fashion - very high performance
Comment 2 RHEL Product and Program Management 2010-02-24 18:04:33 EST
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 4 Perry Myers 2010-11-23 17:17:55 EST
sdake, can you provide some information on how udpu would be configured in Corosync and used?  This will give us a better idea of what other areas (aside from Luci) need integration work.  Example config files would help here I think.

For example, will we need to expose udpu configuration as part of cluster.conf?  That will mean cloning this bug for cluster component as well and making sure we update the schema.
Comment 6 Steven Dake 2010-11-24 13:34:50 EST
Bug #657041 is the cman bugzilla related to this RFE.  The patch has been merged into stable31 to support this feature.
Comment 7 Steven Dake 2010-11-24 13:40:45 EST
From corosync.conf man page:

       member This  specifies a member on the interface and used with the udpu
              transport only.  Every node that should be a member of the  mem-
              bership  should  be  specified  as  a separate member directive.
              Within the member directive  there  is  a  parameter  memberaddr
              which specifies the ip address of one of the nodes.

An example corosync.conf showing 16 nodes is attached to this bugzilla.

In the case of cman, the "transport" should be changed to "udpu".  Honza will provide necessary information to make that work in Bug #657041.
Comment 8 Steven Dake 2010-11-24 13:41:45 EST
Created attachment 462725 [details]
example configuration file for those that configure udpu via corosync.conf (and not using the cman service engine)
Comment 9 Steven Dake 2010-12-02 13:51:20 EST
Created attachment 464333 [details]
patch 1 to add udpu support
Comment 10 Steven Dake 2010-12-02 13:51:52 EST
Created attachment 464334 [details]
patch 2 to add udpu support
Comment 11 Steven Dake 2010-12-02 13:52:28 EST
Created attachment 464335 [details]
patch 3 for udpu support
Comment 12 Steven Dake 2010-12-02 13:52:57 EST
Created attachment 464336 [details]
patch 4 to add udpu support
Comment 14 Steven Dake 2011-03-01 13:20:25 EST
*** Bug 681269 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2011-05-19 10:23:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0764.html

Note You need to log in before you can comment on or make changes to this bug.