Bug 56820 - apmd default kills NIS logins
apmd default kills NIS logins
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 04:10 EST by Andrew Gormanly
Modified: 2007-03-26 23:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 18:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Gormanly 2001-11-28 04:10:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-12 i686)

Description of problem:
apmd is enabled by default, and set to shutdown the network after 10
minutes idle.  This logs out users with NIS accounts and automounted home
directories, which seems to be a bad thing for a default set up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ypbind at installation time
2. log in with an NIS account
3. wait 10 minutes.
	

Actual Results:  Screen is blank.  On pressing a key see gdm, not user's
work.

Expected Results:  Power saving to not log users out as default setting.

Additional info:

I think the system defaults should not be set in ways which break very
common configurations (i.e. NFS & NIS clusters).  NET_RESTART="yes" can be
very useful I guess, but it can cause pain too.  Default settings should
IMHO be quite conservative + not risk breaking things...
Comment 1 Bernhard Rosenkraenzer 2002-02-26 12:56:36 EST
 We don't default to shutting down after 10 minutes of idle time. That may be something 
your BIOS does. 
 
NET_RESTART is set to yes by default because that's the more conservative and less risky 
setting - quite a few (from my own experience, I'd say 90%) of all notebook network 
chipsets and PCMCIA network cards don't work after a resume unless they're restarted. 
 
Furthermore, NET_RESTART=no in combiniation with dhcp is a major problem (you can't expect 
to keep the IP over a suspend/resume cycle, so you need to restart the network in this 
case, as well). 
 
Because of these things, I think our current default settings are correct. 

Note You need to log in before you can comment on or make changes to this bug.