Bug 568219 - PartitionException: Too many primary partitions.
PartitionException: Too many primary partitions.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:b474865b3014fecec...
:
: 578553 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker 585028
  Show dependency treegraph
 
Reported: 2010-02-24 22:48 EST by He Rui
Modified: 2013-01-10 10:47 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-13.39-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 585028 (view as bug list)
Environment:
Last Closed: 2010-05-04 20:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (465.83 KB, text/plain)
2010-02-24 22:48 EST, He Rui
no flags Details
Attached traceback automatically from anaconda. (332.59 KB, text/plain)
2010-02-26 01:29 EST, He Rui
no flags Details
Attached traceback automatically from anaconda. (431.52 KB, text/plain)
2010-02-26 07:12 EST, He Rui
no flags Details
Attached traceback automatically from anaconda. (332.61 KB, text/plain)
2010-02-26 16:22 EST, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (221.24 KB, text/plain)
2010-02-26 16:29 EST, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (170.63 KB, text/plain)
2010-03-19 16:04 EDT, Stephan Dühr
no flags Details
Attached traceback automatically from anaconda. (461.16 KB, text/plain)
2010-03-23 02:24 EDT, He Rui
no flags Details
Attached traceback automatically from anaconda. (428.29 KB, text/plain)
2010-03-23 18:52 EDT, Steve Tyler
no flags Details
Attached traceback automatically from anaconda. (470.39 KB, text/plain)
2010-03-29 02:55 EDT, He Rui
no flags Details
Attached traceback automatically from anaconda. (298.67 KB, text/plain)
2010-03-29 03:41 EDT, He Rui
no flags Details
Attached traceback automatically from anaconda. (285.18 KB, text/plain)
2010-04-13 20:50 EDT, maximus0206
no flags Details

  None (edit)
Description He Rui 2010-02-24 22:48:50 EST
The following was filed automatically by anaconda:
anaconda 13.31 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 246, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in addPartition
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 272, in addPartition
    constraint=constraint)
  File "/usr/lib/anaconda/storage/devices.py", line 1257, in create
    self.disk.format.addPartition(self.partedPartition)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 672, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 290, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Too many primary partitions.
Comment 1 He Rui 2010-02-24 22:48:56 EST
Created attachment 396209 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2010-02-25 07:26:42 EST
Hi Hurry, can you provide a few steps that you use to reproduce this failure?  THanks!
Comment 3 He Rui 2010-02-25 22:37:41 EST
Sorry I forgot..

Description of problem:

I tried to install Fedora-13-Alpha-RC3 on a F12 existing system. At Partitioning step, I selected Create custom layout and added /boot, / (swap) manually. 

Version-Release number of selected component (if applicable):
 * Fedora-13-Alpha-RC3
 * anaconda 13.31

How reproducible:
100%

Steps to Reproduce:
1. Boot netinst.iso
2. Proceed through install to partitioning step:

a. Choose create cumstom layout and click next.
b. Create 500M ext4 /boot /dev/sda5.
c. Create 5000M ext4 / /dev/sda6.
(d. Create 500M swap /dev/sda7.)

3. Exception Occurred after clear next.

Note: I executed the same steps on anaconda 13.29 of rc2, it hanged or exception occurred with different status. please see bug 567576.
Comment 4 He Rui 2010-02-26 01:29:52 EST
Created attachment 396484 [details]
Attached traceback automatically from anaconda.
Comment 5 He Rui 2010-02-26 01:32:23 EST
reproduced in f13-alpha-RC4
Comment 6 He Rui 2010-02-26 07:12:43 EST
Created attachment 396526 [details]
Attached traceback automatically from anaconda.
Comment 7 Clyde E. Kunkel 2010-02-26 16:22:26 EST
Created attachment 396678 [details]
Attached traceback automatically from anaconda.
Comment 8 Clyde E. Kunkel 2010-02-26 16:29:20 EST
Created attachment 396679 [details]
Attached traceback automatically from anaconda.
Comment 9 Clyde E. Kunkel 2010-02-26 17:16:41 EST
These tracebacks occurred in a rawhide VM.  Was trying to create, in the first instance a raid 10 device to be used as a PV and in the second case, just create standard PVs.  First problem arose when creating the VG and the second when trying to format the LV.
Comment 11 Stephan Dühr 2010-03-19 16:04:50 EDT
Created attachment 401340 [details]
Attached traceback automatically from anaconda.
Comment 12 Stephan Dühr 2010-03-19 16:14:45 EDT
In my case this happens because of an empty logical partition, this was already reported for F12, see https://bugzilla.redhat.com/show_bug.cgi?id=540808#c3
Comment 13 Stephan Dühr 2010-03-19 16:29:05 EDT
Unlike https://bugzilla.redhat.com/show_bug.cgi?id=540808#c2 in my case the partitions are in disk order:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2f4a2f49

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4904    39391348+   7  HPFS/NTFS
/dev/sda2            4905       17653   102406342+   7  HPFS/NTFS
/dev/sda3           17654       30401   102398310    f  W95 Ext'd (LBA)
Comment 14 He Rui 2010-03-23 02:24:01 EDT
Created attachment 401944 [details]
Attached traceback automatically from anaconda.
Comment 15 Steve Tyler 2010-03-23 18:52:08 EDT
Created attachment 402164 [details]
Attached traceback automatically from anaconda.
Comment 16 Steve Tyler 2010-03-23 19:02:46 EDT
(In reply to comment #15)
> Created an attachment (id=402164) [details]
> Attached traceback automatically from anaconda.

Here are the partitions before and after.
13.36
F13-Beta-TC1 Live image installed on a USB stick

[root@localhost liveuser]# fdisk -l /dev/sdb

Disk /dev/sdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xff3d5e55

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14        4418    35383162+  8e  Linux LVM
/dev/sdb3            4419        4802     3082399   83  Linux
/dev/sdb4            4802        4866      512000    5  Extended
/dev/sdb5            4802        4866      510976   82  Linux swap / Solaris
[root@localhost liveuser]# fdisk -l /dev/sdb

Disk /dev/sdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xff3d5e55

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14        4418    35383162+  8e  Linux LVM
/dev/sdb4            4802        4866      512000    5  Extended
[root@localhost liveuser]#
Comment 17 David Lehman 2010-03-24 12:13:19 EDT
Updates available for testing:

  http://dlehman.fedorapeople.org/updates-568219.img

That's against anaconda-13.36-1, so it may not work with older versions of anaconda. Please test, if possible, and provide feedback.
Comment 18 He Rui 2010-03-29 02:55:16 EDT
Created attachment 403196 [details]
Attached traceback automatically from anaconda.
Comment 19 He Rui 2010-03-29 03:41:23 EDT
Created attachment 403208 [details]
Attached traceback automatically from anaconda.
Comment 20 He Rui 2010-03-29 03:55:15 EDT
(In reply to comment #17)
> Updates available for testing:
> 
>   http://dlehman.fedorapeople.org/updates-568219.img
> 
> That's against anaconda-13.36-1, so it may not work with older versions of
> anaconda. Please test, if possible, and provide feedback.    

Reproduced this issue. Please refer to comment 19. The steps are:

1. The original system must contain extended partition.

2. Install another system, delete the partitions in the extended partition one by one (sda5 and above).(Note: delete extended partition directly won't make this issue happen.)

3. Create new ext4 partitions.

4. Exception occurred.
Comment 21 maximus0206 2010-04-13 20:50:04 EDT
Created attachment 406389 [details]
Attached traceback automatically from anaconda.
Comment 22 Adam Williamson 2010-04-16 11:48:03 EDT
Discussed at today's blocker bug review meeting. Accepted as a blocker as it infringes:

"The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"

https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Fedora Update System 2010-04-28 17:08:49 EDT
anaconda-13.39-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.39-1.fc13
Comment 24 Adam Williamson 2010-05-03 10:46:37 EDT
rhe: can you please re-test with anaconda 13.39? I think the nightly live images should include it at least, by now. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Adam Williamson 2010-05-03 20:26:00 EDT
actually, it's included in tc1, so just test with that.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Adam Williamson 2010-05-04 18:40:23 EDT
we need someone else to test this, as Chinese office is on holiday. I can't, due to my current resources. James, can you, following Rui's reproduction steps?
Comment 27 Jesse Keating 2010-05-04 20:20:16 EDT
I tested this following the steps above, and was not able to reproduce it.  Calling it fixed.
Comment 28 alien_life_form 2010-07-13 06:21:56 EDT
I have the same issue with anaconda 13.42/i386

System (Dell XPS) has BIOS RAID, with three WIN partions (factory tools, factory restore, win7). Any partitioning scheme (manual w/standard partions (no lvm), lvm auto, lvm review fails, fails with "too many primary partions".

I tried to prepartition the disk, telling anaconda to replace existing partitions, which led to what follows (prob'ly a separete bug):

 Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1070, in populate
    devstring = device.name
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1844, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1393, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1405, in setScreen
    return self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1314, in nextClicked
    self.setScreen ()
 AttributeError: 'NoneType' object has no attribute 'name'

(full traceback had separately been reported here: [http://www.google.it/url?sa=t&source=web&cd=1&ved=0CBcQFjAA&url=http%3A%2F%2Fforums.fedoraforum.org%2Fattachment.php%3Fattachmentid%3D19742%26d%3D1277495147&ei=Fj08TIzkD47-OdvG5MQP&usg=AFQjCNESY6NU1mDaHd7ic2N9WNVFL4Pr3A&sig2=a9sl-DTePlck5vAxRunNXQ])
Comment 29 Brian Lane 2010-07-21 16:18:13 EDT
*** Bug 578553 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.