Bug 568235 - Loader received SIGSEGV
Summary: Loader received SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-02-25 05:01 UTC by Clyde E. Kunkel
Modified: 2014-09-30 23:38 UTC (History)
11 users (show)

Fixed In Version: anaconda-13.32-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-26 21:05:27 UTC


Attachments (Terms of Use)
anaconda 13.31 sigsegv backtrace (640.72 KB, image/jpeg)
2010-02-25 05:01 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2010-02-25 05:01:39 UTC
Created attachment 396215 [details]
anaconda 13.31 sigsegv backtrace

Description of problem:
Loader received SIGSEGV during inititialization

Version-Release number of selected component (if applicable):
13.31

How reproducible:
Every time

Steps to Reproduce:
1. boot x86_64 Alpha RC3 DVD
2. accept defaults or not--doesn't make any difference
3.
  
Actual results:
SIGSEGV

Expected results:
normal installation

Additional info:
Noticed that the kernel command line info in tty-4 was garbage.

Screen shot of backtrace attached.

Comment 1 Clyde E. Kunkel 2010-02-25 05:20:11 UTC
Tried boot.iso with 13.30 and it works.

Comment 2 He Rui 2010-02-25 09:03:11 UTC
same results when testing alpha-rc3-x86_64 (not happen in i386).

The screen displayed:
running install...
running /sbin/loader
loader received SIGSEGV! Backtrace:
/sbin/loader[0x408f73]
/lib64/libc.so.6(+0x337f0)[0x7f3ab15c67f0]
/lib64/libc.so.6(_IO_vfprintf+0x3606)[0x7f3ab15db726]
/lib64/libc.so.6(__vfprintf_chk+0x77)[0x7f3ab168c467]
/sbin/loader[0x40c88a]
/sbin/loader[0x40c996]
/sbin/loader[0x407bee]
/sbin/loader[0x40a0b8]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7f3ab15b1d2d]
/sbin/loader[0x406f29]
install exited abnormally [1/1]
The system will be rebooted when you press ctrl-c or ctrl-alt-delete.

Comment 3 Ales Kozumplik 2010-02-25 11:43:36 UTC
A patch for the issue is ready, waiting for a review:
https://www.redhat.com/archives/anaconda-devel-list/2010-February/msg00361.html

Comment 4 Jesse Keating 2010-02-25 19:12:26 UTC
Tested patch committed upstream and waiting for a new anaconda build.

Comment 5 Fedora Update System 2010-02-25 21:41:58 UTC
anaconda-13.32-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.32-1.fc13

Comment 6 Ales Kozumplik 2010-02-26 06:57:31 UTC
Oh yeah,

fix has been on the branch since yesterday 3556a3d70867a30be61ecb64e32a5ddfecc9d89b, released in anaconda-13.32.

Ales

Comment 7 Fedora Update System 2010-02-26 11:50:48 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2985

Comment 8 Orion Poplawski 2010-02-26 16:34:01 UTC
Fixed it for me.

Comment 9 Clyde E. Kunkel 2010-02-26 19:02:42 UTC
13.32 works for me.

Comment 10 James Laska 2010-02-26 21:05:27 UTC
Confirmed fixed in anaconda-13.32 (F-13-Alpha-RC4-x86_64).

Comment 11 Fedora Update System 2010-02-27 12:58:00 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-02-28 14:45:54 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-03-01 01:40:28 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-03-02 00:59:31 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-03-03 01:59:26 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-03-03 08:17:13 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-03-04 00:22:17 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-03-04 01:32:48 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-03-05 03:32:24 UTC
anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.