Bug 568236 - [abrt] crash in octave-6:3.2.3-4.fc12: Process /usr/bin/octave-3.2.3 was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in octave-6:3.2.3-4.fc12: Process /usr/bin/octave-3.2.3 was kill...
Keywords:
Status: CLOSED DUPLICATE of bug 562276
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:80b62075d296933651ccfb26652...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-25 05:06 UTC by Jim Shipman
Modified: 2010-07-04 02:47 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-04 02:47:50 UTC


Attachments (Terms of Use)
File: backtrace (22.42 KB, text/plain)
2010-02-25 05:06 UTC, Jim Shipman
no flags Details

Description Jim Shipman 2010-02-25 05:06:43 UTC
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: octave --eval 'PS1(\'PS1('oc\\PS\'PS1('o\'PS1('oc\\PS1\'PS1('octav\'PS1('octave:\#>');PS2('octave:\#+>'\'P' --persist -H -i
comment: I was starting the program from the main menu.
component: octave
executable: /usr/bin/octave-3.2.3
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: octave-6:3.2.3-4.fc12
rating: 4
reason: Process /usr/bin/octave-3.2.3 was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Jim Shipman 2010-02-25 05:06:48 UTC
Created attachment 396216 [details]
File: backtrace

Comment 2 QFanatic 2010-03-13 15:09:52 UTC

How to reproduce
-----
1.Happens on initial startup
2.
3.

Comment 3 Xion Luhnis 2010-03-15 23:09:27 UTC

How to reproduce
-----
1. Start QtOctave

Comment
-----
When starting QtOctave, it starts and crashes.
Then, it reloads something... and all is ok (but there's this crash bug and the bug report tool notification).

Comment 4 QFanatic 2010-03-16 20:35:32 UTC

How to reproduce
-----
1.Happens on initial startup of QtOctave
2.
3.


Comment
-----
>>>warning: mark_as_command is obsolete and will be removed from a future versi
on of Octave
>>>panic: Segmentation fault -- stopping myself...
attempting to save variables to `octave-core'...
save to `octave-core' complete

This is the error message received.  I noticed that the >>> appeared before the warning before the crash.  When the warning appears normally the >>> does not appear before the warning, ie. 
warning: mark_as_command is obsolete and will be removed from a future version 
of Octave

Comment 5 QFanatic 2010-04-17 14:53:32 UTC

How to reproduce
-----
1.save a large file of variables in QtOctave: ie. save largefile.mat;
2.shutdown and restart QtOctave
3.attempt to load largefile.mat ie: load largefile.mat;


Comment
-----
This seems to cause the same segmentation fault that occasionally occurs on startup.  Since the Octave startup includes reloading the last set of variables in use it seems likely that this is related, if not the same problem.  I examined the data file that caused the crash, a number of the variables had changed, possibly due to rounding error, to become much higher precision.  Possibly some type of register overflow might occur.  This saved file also crashes vanilla Octave if you attempt to load it, with the same segmentation fault.

Comment 6 Alex Lancaster 2010-04-17 19:45:29 UTC
(In reply to comment #5)
> 
> How to reproduce
> -----
> 1.save a large file of variables in QtOctave: ie. save largefile.mat;
> 2.shutdown and restart QtOctave
> 3.attempt to load largefile.mat ie: load largefile.mat;

Can you reproduce with vanilla command-line octave?  If not, then this is most likely qtoctave-specific and probably need to switch the Bugzilla component and/or discuss with upstream qtoctave.

Comment 7 Dave Comer 2010-04-17 21:28:56 UTC

Comment
-----
Exited QtOctave. This seems to generate an Octave Crash.

Comment 8 Enrique Gomezdelcampo 2010-05-10 16:13:22 UTC
Hi,

This bug is still there in the new version of qtoctave (qtoctave-0.9.1.1.fc12.x86_64). Any proposed fix?

Thanks,
Enrique

Comment 9 Alex Lancaster 2010-07-04 02:47:50 UTC
This is almost certainly a dupe of bug #562276 and the problem is with octave-forge, not qtoctave per se.

*** This bug has been marked as a duplicate of bug 562276 ***


Note You need to log in before you can comment on or make changes to this bug.