Bug 56829 - lastcomm doesn't seem to understand 32-bit UIDs
lastcomm doesn't seem to understand 32-bit UIDs
Status: CLOSED DUPLICATE of bug 62481
Product: Red Hat Linux
Classification: Retired
Component: psacct (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 10:34 EST by Christopher Penney
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 18:05:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Penney 2001-11-28 10:34:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.2)
Gecko/20011002 Netscape6/6.1

Description of problem:
We use process accounting.  The report generated by lastcomm does not seem
to understand 32-bit UIDs.  Instead we are getting the low order 16-bits of
the UID displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enable process accounting and install the psacct RPM
2.Create a user with a UID greater than 64k (in my example, cpenney -> 637911)
3.Execute some commands (in my example, /sbin/ifconfig)
3.Run lastcomm



Actual Results:  
% lastcomm
ifconfig                48087    stdin      0.00 secs Wed Nov 28 10:26



Expected Results:  
% lastcomm
ifconfig                cpenney  stdin      0.00 secs Wed Nov 28 10:26


Additional info:

My UID in hex is 9BBD7.  The UID it shows is BBD7 in hex so it's obviously
stripping off the top 16-bits of the UID.  I'm not sure if this is an issue
with the psacct utilities or the process accounting code in the kernel.  I
tried doing some searching, but to no avail.
Comment 1 Mike A. Harris 2002-03-12 04:51:28 EST
This is not a bug in lastcomm not psacct.  The kernel process accounting
features do not support 32bit UID at all.  As such, it is more of a
lack of a feature than a bug.  I discovered this while troubleshooting
other bugs in lastcomm.
Comment 2 Mike A. Harris 2002-04-01 18:08:04 EST
have looked into adding support for this in a compatible manner and have
made a kernel patch adding 32bit uid/gid support.  I am currently working
on userland support as well.


*** This bug has been marked as a duplicate of 62481 ***

Note You need to log in before you can comment on or make changes to this bug.