Bug 568396 - KeyError: <yuminstall.AnacondaYumRepo object at 0xb3f7eb0c>
KeyError: <yuminstall.AnacondaYumRepo object at 0xb3f7eb0c>
Status: CLOSED DUPLICATE of bug 505189
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:81befbddd364f9085...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-25 11:25 EST by James Laska
Modified: 2013-09-02 02:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 10:58:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (752.24 KB, text/plain)
2010-02-25 11:25 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (615.81 KB, text/plain)
2010-03-18 09:41 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-02-25 11:25:09 EST
The following was filed automatically by anaconda:
anaconda 13.31 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 233, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 268, in __getattr__
    (self.pkgId,)).fetchone()
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 646, in _remote_path
    return self.relativepath
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 751, in localPkg
    rpmfn = os.path.basename(self.remote_path)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 206, in populateTs
    rpmfile = txmbr.po.localPkg()
  File "/usr/lib/anaconda/yuminstall.py", line 899, in run
    self.populateTs(keepold=0)
  File "/usr/lib/anaconda/yuminstall.py", line 1687, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 300, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1334, in handleRenderCallback
    self.currentWindow.renderCallback()
KeyError: <yuminstall.AnacondaYumRepo object at 0xb3f7eb0c>
Comment 1 James Laska 2010-02-25 11:25:13 EST
Created attachment 396318 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2010-02-25 11:32:30 EST
= Steps to reproduce =
1. Boot from disc1 ISO
2. Proceed with a default install
3. At reposet, click Next
4. A dialog appears noting that discs#1 and #2 will be needed, press Back
5. Select the 'Installation source' repository
6. Select 'Modify repository', make no changes, then press OK
7. Select Next, to proceed with install

= Additional information =
 * NOTE, if I do not fiddle with the CD/DVD repository in steps 5-6, the CDROM install completes successfully
Comment 3 Chris Lumens 2010-02-26 10:58:55 EST

*** This bug has been marked as a duplicate of bug 505189 ***
Comment 4 James Laska 2010-03-18 09:41:44 EDT
Created attachment 401022 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.