Bug 568415 - 2.6.33 kernels don't boot as domU
2.6.33 kernels don't boot as domU
Status: CLOSED DUPLICATE of bug 571241
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-02-25 12:25 EST by Kevin Fenzi
Modified: 2010-04-07 23:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-04-07 23:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2010-02-25 12:25:53 EST
Fedora rawhide guest on a RHEL5 host using xen. 

2.6.32 kernels work fine. 
2.6.33 kernels fail to boot. 

From kernel-2.6.33-4.fc13.x86_64:

PCI: Fatal: No config space access function found
BUG: unable to handle kernel paging request at ffff880001485000
IP: [<ffffffff8102ec62>] free_init_pages+0xb2/0xdb
PGD 1a44067 PUD 1a48067 PMD 4feb067 PTE 10000001485025
Oops: 0003 [#1] SMP 
last sysfs file: 
CPU 3 
Pid: 1, comm: swapper Not tainted 2.6.33-4.fc13.x86_64 #1 /
RIP: e030:[<ffffffff8102ec62>]  [<ffffffff8102ec62>] free_init_pages+0xb2/0xdb
RSP: e02b:ffff8800b830be60  EFLAGS: 00010286
RAX: 00000000cccccccc RBX: ffff880001600000 RCX: 0000000000000400
RDX: ffff880001485000 RSI: 0000000000000000 RDI: ffff880001485000
RBP: ffff8800b830be90 R08: 0000000000002e3e R09: ffffffff8107ba78
R10: ffffffff81a569f8 R11: 0000000000000000 R12: ffff880001485000
R13: 0000000000000400 R14: ffffea0000000000 R15: 00000000cccccccc
FS:  0000000000000000(0000) GS:ffff8800083bd000(0000) knlGS:0000000000000000
CS:  e033 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: ffff880001485000 CR3: 0000000001a43000 CR4: 0000000000002620
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000000
Process swapper (pid: 1, threadinfo ffff8800b830a000, task ffff8800b8310000)
 0000000000000000 ffff880000000000 6db6db6db6db6db7 ffffffff81a00000
<0> 0000000000a00000 0000000000000000 ffff8800b830bec0 ffffffff8102efe3
<0> ffffffff81e4c6e8 ffffffff81ba3050 0000000000000200 0000000000000200
Call Trace:
 [<ffffffff8102efe3>] mark_rodata_ro+0xea/0x151
 [<ffffffff810021ea>] init_post+0x30/0x116
 [<ffffffff81d827b2>] kernel_init+0x260/0x26f
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff814790d0>] ? restore_args+0x0/0x30
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
Code: c5 49 00 00 48 c1 e8 0c 4c 89 e2 4c 89 e9 48 6b c0 38 48 81 e2 00 f0 ff ff 31 f6 48 89 d7 4c 01 f0 c7 40 08 01 00 00 00 44 89 f8 <f3> ab 4c 89 e7 49 81 c4 00 10 00 00 e8 33 14 0b 00 48 ff 05 46 
RIP  [<ffffffff8102ec62>] free_init_pages+0xb2/0xdb
 RSP <ffff8800b830be60>
CR2: ffff880001485000
---[ end trace a9fe02a7fb3d954a ]---
swapper used greatest stack depth: 4664 bytes left
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: swapper Tainted: G      D    2.6.33-4.fc13.x86_64 #1
Call Trace:
 [<ffffffff81475a59>] panic+0x7a/0x142
 [<ffffffff8105404b>] ? do_exit+0x3a8/0x7a5
 [<ffffffff81053d1e>] do_exit+0x7b/0x7a5
 [<ffffffff81478db2>] ? _raw_spin_unlock_irqrestore+0x40/0x56
 [<ffffffff8147a00b>] oops_end+0xbf/0xc7
 [<ffffffff8102fc35>] no_context+0x1fc/0x20b
 [<ffffffff8107ba78>] ? trace_hardirqs_off+0xd/0xf
 [<ffffffff8102fdd6>] __bad_area_nosemaphore+0x192/0x1b5
 [<ffffffff81004435>] ? __raw_callee_save_xen_pmd_val+0x11/0x1e
 [<ffffffff8102fe0c>] bad_area_nosemaphore+0x13/0x15
 [<ffffffff8147bb40>] do_page_fault+0x1c1/0x331
 [<ffffffff81479375>] page_fault+0x25/0x30
 [<ffffffff8107ba78>] ? trace_hardirqs_off+0xd/0xf
 [<ffffffff8102ec62>] ? free_init_pages+0xb2/0xdb
 [<ffffffff8102efe3>] mark_rodata_ro+0xea/0x151
 [<ffffffff810021ea>] init_post+0x30/0x116
 [<ffffffff81d827b2>] kernel_init+0x260/0x26f
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff814790d0>] ? restore_args+0x0/0x30
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10

Happy to try and gather more info or assist in tracking this down.
Comment 1 Andrew Jones 2010-02-25 13:07:22 EST
Thanks for the bug report. I think this is new, but for some reason I feel like I've seen it somewhere. Although my quick search of the upstream xen-devel mailing list didn't pop it up.

Since booting used to work and doesn't now, then the easiest way to start is with bisection. If you don't mind, can you do a higher granularity bisection pass with the kernels that are available at the link below between the last-known good and the first-known bad?


Once we've narrowed it down to a distance of one koji build, then we can use git bisection to further narrow it down to a patch.

Comment 2 Kevin Fenzi 2010-02-25 15:14:27 EST
I'll try and do this, but the machine is a compose host, so it's busy a lot of the time. ;( 

Will see what I can come up with.
Comment 3 Kevin Fenzi 2010-03-29 11:20:05 EDT
Looks like this is a dup of 571241 which has a patch. ;)
Comment 4 Kevin Fenzi 2010-04-07 23:01:21 EDT

*** This bug has been marked as a duplicate of bug 571241 ***

Note You need to log in before you can comment on or make changes to this bug.