Bug 568488 - yum-plugin-auto-update-debug-info should not affect 'install'
yum-plugin-auto-update-debug-info should not affect 'install'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-25 15:09 EST by Roland McGrath
Modified: 2014-01-21 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 16:09:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2010-02-25 15:09:58 EST
I love this plug-in for keeping my installed debuginfo packages up to date.
But, I also want to be able to use 'yum install foobar*' and get all the foobar packages without getting foobar-debuginfo.  So, to match its name, the plugin should apply on 'yum update' and 'yum upgrade', but not in 'yum install'.  Conversely, some hack that enabled the repos but excluded the debuginfo repos from being used for wildcard expansion would also work.
Comment 1 Tim Lauridsen 2010-05-05 09:31:44 EDT
All what the plugins does is to enable the '*-debuginfo' repos for the active repositories.
It is a TYPE_CORE plugin so it is active for all consumers of the yum api, not just yum-cli.

So there is no way to limit it to 'yum update'.

you can disable the plugin so it don't run every time and use the '--enableplugin=auto-update-debuginfo' to enable it when you want it.

(hint : you can use the yum-plugin-aliases to create an alias for --enableplugin=auto-update-debuginfo, if you dont wan't to type so much )
Comment 2 Roland McGrath 2010-05-05 15:04:43 EDT
The plugin is misnamed if that's all it's ever going to do.  Rename it to yum-auto-debuginfo or something, or else implement it in whatever way makes it actually do what it says it does.
Comment 3 James Antill 2010-05-05 16:09:50 EDT
So the problem is that the way the plugin works is that it looks to see if you have any debuginfo packages installed already, and _if you do_ it then enables the debuginfo repos. ... so that updates work. The name reflects that, and people's desire that "I've installed debuginfos and I want them to automatically update".

Yes, after you've installed at least one debuginfo rpm, you can then install more debuginfos but that's kind of an edge case. It's also fair to say that I _very rarely_ see people use "yum install 'foo*'" commands.

Note You need to log in before you can comment on or make changes to this bug.