Bug 56851 - sndconfig fails to configure CS4236B card in Thinkpad 380Z (2635-HGF)
sndconfig fails to configure CS4236B card in Thinkpad 380Z (2635-HGF)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 14:50 EST by Jean-Philippe Jung
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 01:04:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Philippe Jung 2001-11-28 14:50:46 EST
Description of Problem:
As root, run sndconfig. PNP detection: "No PnP or PCI sound cards...". In the menu, select "Crystal CS423x sound chip". Manually pass the values I got from Windows 98:
I/O Port=0x530, IRQ=10, DMA1=1, DMA2=0, MPU I/O=0x300, MPU IRQ=9.
I press OK. The screen stays all blue (background screen for Sound
Configuration Utility 0.65.2 for about 5 or 6 seconds then displays: "Sound Card  Test", "A sample sound will now be played...". I press OK. The screen stays again all blue for about 5-6 seconds and then displays: "modprobe error"
"The following error occured running the modprobe program:
/lib/modules/2.4.7-10/kernel/drivers/sound/cs4232.o:
init_module: No such device
/lib/modules/2.4.7-10/kernel/drivers/sound/cs4232.o: insmod
/lib/modules/2.4.7-10/kernel/drivers/sound/cs4232.o failed
/lib/modules/2.4.7-10/kernel/drivers/sound/cs4232.o: insmod
sound-slot-0 failed" Reading a bit more lead me to displaying used resources. cat /proc/ioports
gave:
()
00f0-00ff : fpu
01f0-01f7 : ide0
0300-031f : 3c574_cs
03c0-03df : vga+
03f0-03f5 : floppy
03f6-03f6 : ide0
03f7-03f7 : floppy DIR
03f8-03ff : serial(set)
0cf8-0cff : PCI conf1
1000-10ff : PCI CardBus #01
() And cat /dev/interrupts gave:
CPU0  
 0:  155197 XT-PIC  timer
 1:    1486  XT-PIC  keyboard
 2:  0  XT-PIC  cascade
 5:   23478  XT-PIC  3c574_cs
 6: 16  XT-PIC  floppy
 8:  1  XT-PIC  rtc
11:  0  XT-PIC  usb-uhci, Texas Instruments PCI1250, Texas Instruments
PCI1250 (#2)
12:348  XT-PIC  PS/2 Mouse
14:   15365 XT-PIC  ide0
NMI:    0
ERR:   0
The cat /proc/dma only gave: " 4: cascade".
I tried again with non conflicting settings, several settings. Every time the
sound test starts, I have a 5 to 6 seconds of "wait" before I get same error
message: "modprobe error". At last, I removed all PC cards from the machine and rebooted.
Tried again to load driver: not better.

Opened support ticket 195189 with RedHat support staff. Made me upgrade to latest patch and kernel (2.4.9-13) using up2date. Not better. Finally received this comment:
"Notify Customer with e-mail notification.
Steffen Technician Response
Dear Jean-Philippe,
you may want to try to load the module with insmod If this doesn't work, could you please file a bug on http://bugzilla.redhat.com
You may want to have a visit to following link as well
http://www.alsa-project.org
and try their driver. Best Regards, Steffen 19-NOV-2001 13:12:42 EST
Request Updated"

I then tried: "Hi, I am quite new to Linux and I would appreciate the correct list of commands to issue, regarding my configuration. I made the following: 
modprobe soundcore
modprobe sound
modprobe ad1848
modprobe uart401 The I try to insert my driver:
insmod cs4232 irq=10 io=0x534 dma=1 dma2=0 mpuio=0x330 mpuirq=9
I played around with parameters, and this does not work: init_module: no such
device. My question is: based on the ressources used by my card under Windows (see
initial post), is this correct? Do I have to pass parameters to the ad1848 and
uart401 drivers? If yes, whhich and how? 28-NOV-2001 05:32:52 EST"

and got:
"28-NOV-2001 10:04:02 EST
Steffen Technician Response
Dear Jean-Philippe,
the parameters look correct. I really can not understand why it is not working,
sound on Laptops can be sometimes tricky, you may want to have a look at
http://www.linux-laptops.net and have a look for your model. Nevertheless plase
file this as well as a bug on http://bugzilla.redhat.com so an engineer will
have a closer look at this problem. Thank you in advance. Regards, Steffen 28-NOV-2001 09:56:40 EST"


Version-Release number of selected component (if applicable):
Sound Configuration Utility 0.65.2

How Reproducible:
Every time.

Steps to Reproduce:
1.Start the machine under Linux RedHat 7.2 with kernel 2.4.9-13
2.Logon as root, switch to INIT 3
3.Run sndconfig and pass correct parameters to the CS4232 driver (correct parameters being parameters that works under Windows 98 - dual boot machine - and that do not conflict with other hardware piece of equipment)

Actual Results:
insmod fails, no sound.

Expected Results:
insmod success, sound :-)

Additional Information:
Comment 1 Bill Nottingham 2002-01-25 01:03:58 EST
Is there anything for your card in /proc/isapnp?
Comment 2 Bill Nottingham 2002-07-22 19:05:55 EDT
closing, lack of response

Note You need to log in before you can comment on or make changes to this bug.