Bug 568556 - custom partitioning fails with error dump
Summary: custom partitioning fails with error dump
Keywords:
Status: CLOSED DUPLICATE of bug 568460
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-26 00:41 UTC by Steve Tyler
Modified: 2010-02-26 20:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-26 15:45:02 UTC


Attachments (Terms of Use)
error dump (347.03 KB, text/plain)
2010-02-26 00:45 UTC, Steve Tyler
no flags Details

Description Steve Tyler 2010-02-26 00:41:48 UTC
Description of problem:
After completing a custom disk layout, I receiving an alert displaying a python backtrace. It is attached.

Version-Release number of selected component (if applicable):
[stephent@walnut fedora]$ ls -l F13-Alpha-i686-Live.iso
-rw-rw-r-- 1 stephent stephent 875560960 2010-02-25 09:28 F13-Alpha-i686-Live.iso
[stephent@walnut fedora]$ sha256sum F13-Alpha-i686-Live.iso
7623e48b2224e79c62ffade96a825942dba43a46b2c16c9a0c2acfa5b7cbccda  F13-Alpha-i686-Live.iso
[stephent@walnut fedora]$ ls -l Fedora-13-Alpha-i386-netinst.iso
-rw-rw-r-- 1 stephent stephent 246415360 2010-02-24 15:19 Fedora-13-Alpha-i386-netinst.iso
[stephent@walnut fedora]$ sha5sum Fedora-13-Alpha-i386-netinst.iso

How reproducible:
Only tried once ...

Steps to Reproduce:
This is what I did:
1. sudo livecd-iso-to-disk --format F13-Alpha-i686-Live.iso /dev/sdc1
(/dev/sdc is an 8GB Lexar USB Flash Drive)
2. Boot the live image from the USB stick and click install ...
3. Choose custom disk layout.
4. I deleted two partitions, recreated two partitions with different sizes, configured one as "/boot" and one as "/", both to be formatted. 
  
Actual results:
Received an error message with a python backtrace.
Neither partition was deleted, but, IIRC, one could not be mounted by gnome-disk-utility. Since I needed a place to put the python dump, I used gnome-disk-utility to format it.

Expected results:
Partitions are created and formatted as specified.

Additional info:

I was trying to delete sdb3 and sdb5 and then recreate them with sdb3 smaller (100 MB for "/boot") and allocate the rest of the space to sdb5 for "/" (Bug 568460 prevented me from choosing a pre-existing logical volume).

[stephent@walnut ~]$ sudo fdisk -l /dev/sdb

Disk /dev/sdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xff3d5e55

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14        4418    35383162+  8e  Linux LVM
/dev/sdb3   *        4419        4483      522112+  83  Linux
/dev/sdb4            4484        4865     3068415    f  W95 Ext'd (LBA)
/dev/sdb5            4484        4865     3068383+  83  Linux

[stephent@walnut ~]$ blkid 
/dev/sda1: UUID="80c8c1fd-cb09-41c9-8404-b8ca010a75bc" TYPE="ext4" LABEL="walnut_boot" 
/dev/sda2: UUID="kT8fYU-UN7Z-If4K-cILr-U2Ak-ebgf-GxBOnv" TYPE="LVM2_member" 
/dev/sdb1: LABEL="cedar_boot" UUID="792d821d-ec1c-44ca-8c90-e98ab92d9650" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdb2: UUID="820rVv-y7zN-gQUx-E8rV-f2ei-Silh-JEQ5kw" TYPE="LVM2_member" 
/dev/sdb3: LABEL="fir_boot" UUID="910e2c62-5d4e-4601-9b80-0c273941c627" TYPE="ext4" 
/dev/sdb5: UUID="163e92f5-96d7-4525-a69c-20091e4a0495" TYPE="ext4" LABEL="linux_spare" 
/dev/sda5: UUID="05fe594a-bd90-44ba-8dbc-2e6c1de27094" TYPE="ext4" LABEL="pecan_root" 
/dev/sda6: UUID="a377bcbc-0c4d-4f9e-b804-15c14d639ab3" TYPE="ext4" LABEL="pecan_home" 
/dev/sda7: UUID="39d61b09-9391-4dbd-ab77-e91ebf7cc8d2" TYPE="swap" 
/dev/mapper/vg_pluto-lv_cedar_root: LABEL="cedar_root" UUID="1bad76a1-2f91-4685-a9f7-de5a82507b79" SEC_TYPE="ext2" TYPE="ext3" 
/dev/mapper/vg_pluto-lv_cedar_home: LABEL="cedar_home" UUID="50e142f5-dc2b-471e-8540-5b21f771e5a5" SEC_TYPE="ext2" TYPE="ext3" 
/dev/mapper/vg_pluto-lv_fir_root: LABEL="fir_root" UUID="829b6aa2-4455-4dd8-9eaf-53427c79b34b" TYPE="ext4" 
/dev/mapper/vg_walnut-lv_walnut_root: LABEL="walnut_root" UUID="578fc9d0-1660-473e-985a-cbe13213edf8" TYPE="ext4" 
/dev/mapper/vg_walnut-lv_walnut_home: LABEL="walnut_home" UUID="84d35996-47ad-4e02-be0d-dd7e815a9a34" TYPE="ext4" 
/dev/mapper/vg_walnut-lv_walnut_swap: UUID="5354a19f-85f7-4b40-b397-65a47097482d" TYPE="swap"

Comment 1 Steve Tyler 2010-02-26 00:45:53 UTC
Created attachment 396437 [details]
error dump

This was supposed to have been attached with report.

Comment 2 Chris Lumens 2010-02-26 01:41:36 UTC
Please attach /tmp/syslog to this bug report as well.  Thanks.

Comment 3 Steve Tyler 2010-02-26 04:46:11 UTC
(In reply to comment #2)
> Please attach /tmp/syslog to this bug report as well.  Thanks.    

Wasn't what I already uploaded enough?
You anaconda people should try actually designing your failure reports ...

https://bugzilla.redhat.com/attachment.cgi?id=396358
Attached by jlaska to Bug 568460 - Anaconda doesn't recognize pre-existing logical volumes ...

James is much more polite than I am ...

http://fedoraproject.org/wiki/Features/ABRT

Comment 4 Chris Lumens 2010-02-26 15:42:19 UTC
> Wasn't what I already uploaded enough?
> You anaconda people should try actually designing your failure reports ...

No, there was no syslog in your original report.  And there's no reason to be a jerk about it.

> http://fedoraproject.org/wiki/Features/ABRT    

I wasn't aware of that, thanks.

Comment 5 Chris Lumens 2010-02-26 15:45:02 UTC
I'm going to dupe this to 568460, since you're seeing the weird thing where partitions are being detected as disklabels.  Note from your traceback:

self: DiskLabel instance (0xad0512c) --
  type = disklabel  name = partition table (MSDOS)  status = False

This matches what's happening in the screenshot from that bug.

*** This bug has been marked as a duplicate of bug 568460 ***

Comment 6 David Lehman 2010-02-26 18:50:19 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Please attach /tmp/syslog to this bug report as well.  Thanks.    
> 
> Wasn't what I already uploaded enough?
> You anaconda people should try actually designing your failure reports ...

Perhaps you should remember that you're using pre-alpha software.

> 
> https://bugzilla.redhat.com/attachment.cgi?id=396358
> Attached by jlaska to Bug 568460 - Anaconda doesn't recognize pre-existing
> logical volumes ...
> 
> James is much more polite than I am ...

And that's why we are all eager to help him out when he needs it.


Thanks for the report, though -- you did help us identify a bug in the reporting mechanism.

Comment 7 Steve Tyler 2010-02-26 20:27:19 UTC
(In reply to comment #6)
...
> Perhaps you should remember that you're using pre-alpha software.

Thanks for reminding me of that.

...
> > James is much more polite than I am ...
> And that's why we are all eager to help him out when he needs it.

OK.

> Thanks for the report, though -- you did help us identify a bug in the
> reporting mechanism.    

Thanks for your feedback! It took me a while to realize that James had identified the problem with the exception report ...


Note You need to log in before you can comment on or make changes to this bug.