Bug 568565 - [abrt] crash in SfxApplication::LeaveBasicCall
Summary: [abrt] crash in SfxApplication::LeaveBasicCall
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2f78e548211fccf1dde5bf36888...
: 588525 (view as bug list)
Depends On: 568884
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-26 01:47 UTC by Ryan Spinuzzi
Modified: 2010-05-04 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-01 10:41:14 UTC


Attachments (Terms of Use)
File: backtrace (38.09 KB, text/plain)
2010-02-26 01:47 UTC, Ryan Spinuzzi
no flags Details
unopkg list > /tmp/custom.list (35 bytes, application/octet-stream)
2010-02-26 18:53 UTC, Ryan Spinuzzi
no flags Details
unopkg list --shared > /tmp/shared.list (19.46 KB, application/octet-stream)
2010-02-26 18:54 UTC, Ryan Spinuzzi
no flags Details
Screen Shot 1 (166.68 KB, image/png)
2010-02-26 21:07 UTC, Ryan Spinuzzi
no flags Details
Screen Shot 2 (15.49 KB, image/png)
2010-02-26 21:07 UTC, Ryan Spinuzzi
no flags Details
Log (2.50 KB, text/plain)
2010-02-26 21:09 UTC, Ryan Spinuzzi
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 109702 None None None Never

Description Ryan Spinuzzi 2010-02-26 01:47:09 UTC
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer /home/Rspinuz/Ineluctable/Customers/RJL/Proposal.odt
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/swriter.bin
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: openoffice.org-writer-1:3.1.1-19.26.fc12
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. ???
2.
3.

Comment 1 Ryan Spinuzzi 2010-02-26 01:47:11 UTC
Created attachment 396445 [details]
File: backtrace

Comment 2 David Tardon 2010-02-26 06:17:41 UTC
You clicked at a menu item that calls a basic macro. Does that ring any bell? Anyway, that menu item had most probably been installed by an extension. Can you attach here a listing of your extensions? I.e. run

unopkg list > /tmp/custom.list

and

unopkg list --shared > /tmp/shared.list

and attach files /tmp/custom.list and /tmp/shared.list here.

Comment 3 Ryan Spinuzzi 2010-02-26 18:52:21 UTC
The last thing that I remember doing was exporting my document as a pdf.  I am not sure but I think I got as far as clicking file, properties, and then it crashed.  I am sorry I wish I could be more helpful.

Comment 4 Ryan Spinuzzi 2010-02-26 18:53:56 UTC
Created attachment 396625 [details]
unopkg list > /tmp/custom.list

Comment 5 Ryan Spinuzzi 2010-02-26 18:54:37 UTC
Created attachment 396626 [details]
unopkg list --shared > /tmp/shared.list

Comment 6 Caolan McNamara 2010-02-26 20:09:38 UTC
hmm. org.openoffice.legacy.extendedPDF from the openoffice.org-extendedPDF extension. That'd be my leading contender. When you exportedto pdf, how did you do it. Via file->export as pdf or via tools->addons->extended pdf/a floating extended pdf icon ?

Comment 7 Ryan Spinuzzi 2010-02-26 20:42:27 UTC
I exported as a pdf through the icon in the tool bar.  Directly after exporting I clicked file, properties, then crash.

I have been trying to reproduce the problem, and no luck so far.  I will keep trying until I do, or the bug is fixed.  If I do then I will post how to reproduce this error, and all other information.

Comment 8 Caolan McNamara 2010-02-26 20:57:57 UTC
Sure, but I think you have two pdf export icons, the builtin one and the one provided by an installed extension. To identify which one it is that you are using, when you hover over the icon with your mouse does it say "extendedPDF" or "Export directly as PDF"

Comment 9 Ryan Spinuzzi 2010-02-26 21:05:47 UTC
Mouse over the tool bar icon says Export as pdf.

Comment 10 Ryan Spinuzzi 2010-02-26 21:06:22 UTC
I tried to reproduce this error by using the tools, addons, extendpdf method. 
I got a runtime error.  I took two screen shots.  The first is a full detail
view, the second is the calls.  I also saved a log of the text found in the
screen shot.  These should be comments 11, 12, and 13.

I am not sure if it will help, but I hope that it does.  If you have any more
questions, or would like me to try something please let me know.  I only know
so much but, I will do what i can to help.

Comment 11 Ryan Spinuzzi 2010-02-26 21:07:02 UTC
Created attachment 396672 [details]
Screen Shot 1

This is a full screen shot

Comment 12 Ryan Spinuzzi 2010-02-26 21:07:37 UTC
Created attachment 396673 [details]
Screen Shot 2

This is a screen shot of just the calls.

Comment 13 Ryan Spinuzzi 2010-02-26 21:09:19 UTC
Created attachment 396675 [details]
Log

This is the text you see in the full screen shot, behind the runtime error box.

Comment 14 Caolan McNamara 2010-02-27 11:45:08 UTC
Yeah, I saw that error dialog as well in extendedPDF. And logged a fix for it as bug #568884. I feel that its related to the actual crash originally reported. It might be that if #568884 is fixed then as a side effect this bug would get fixed as well.

Comment 15 Caolan McNamara 2010-03-01 10:41:14 UTC
Found a read past of of string in basic which might be the cause for this. Can't reproduce the actual crash though, so not certain. Filed fix for the helper app as our bug #568884, that should be fixed. And filed fix for read past string upstream which should also be fixed. Might be a third problem that causes the exact reported crash, but can't find it.

Comment 16 Caolan McNamara 2010-05-04 07:47:07 UTC
*** Bug 588525 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.