Bug 568567 - TypeError: writeGrub() takes at least 7 non-keyword arguments (6 given)
Summary: TypeError: writeGrub() takes at least 7 non-keyword arguments (6 given)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:15d6246a1e8c84488...
: 577001 (view as bug list)
Depends On:
Blocks: F13Beta, F13BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-02-26 02:09 UTC by shmuel siegel
Modified: 2010-03-26 19:53 UTC (History)
10 users (show)

Fixed In Version: anaconda-13.33-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-26 21:07:09 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (278.43 KB, text/plain)
2010-02-26 02:09 UTC, shmuel siegel
no flags Details
Attached traceback automatically from anaconda. (204.32 KB, text/plain)
2010-03-01 08:03 UTC, He Rui
no flags Details
Attached traceback automatically from anaconda. (285.26 KB, text/plain)
2010-03-02 15:09 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (608.51 KB, text/plain)
2010-03-11 21:19 UTC, Edwin Schepers
no flags Details
Attached traceback automatically from anaconda. (265.04 KB, text/plain)
2010-03-18 13:54 UTC, Jeff Layton
no flags Details
Attached traceback automatically from anaconda. (386.22 KB, text/plain)
2010-03-19 23:32 UTC, Martin Ebourne
no flags Details
Attached traceback automatically from anaconda. (205.57 KB, text/plain)
2010-03-26 19:53 UTC, Eric Blake
no flags Details

Description shmuel siegel 2010-02-26 02:09:09 UTC
The following was filed automatically by anaconda:
anaconda 13.31 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/x86.py", line 502, in write
    upgrade = True)
  File "/usr/lib/anaconda/bootloader.py", line 217, in writeBootloader
    kernelList, otherList, defaultDev)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1334, in handleRenderCallback
    self.currentWindow.renderCallback()
TypeError: writeGrub() takes at least 7 non-keyword arguments (6 given)

Comment 1 shmuel siegel 2010-02-26 02:09:15 UTC
Created attachment 396446 [details]
Attached traceback automatically from anaconda.

Comment 2 shmuel siegel 2010-02-26 02:35:47 UTC
This was a DVD upgrade of a fedora 13 system. Upon rebooting, I seem to have a working system

Comment 3 He Rui 2010-03-01 08:03:44 UTC
Created attachment 396981 [details]
Attached traceback automatically from anaconda.

Comment 4 James Laska 2010-03-02 15:09:19 UTC
Created attachment 397346 [details]
Attached traceback automatically from anaconda.

Comment 5 James Laska 2010-03-05 18:19:08 UTC
http://jlaska.fedorapeople.org/updates-568567.img available to work around this issue in F-13-Alpha.

Added to CommonBugs at https://fedoraproject.org/wiki/Common_F13_bugs#writeGrub-upgrade-error

Comment 6 Edwin Schepers 2010-03-11 21:19:08 UTC
Created attachment 399454 [details]
Attached traceback automatically from anaconda.

Comment 7 Edwin Schepers 2010-03-11 21:40:28 UTC
This was on an upgrade. The popupmessage "installing bootloader" could have been the last message. I saw it when pressing ok or reboot or something.
The system seems to function normally and upgraded after reboot.

Comment 8 Jeff Layton 2010-03-18 13:54:15 UTC
Created attachment 401024 [details]
Attached traceback automatically from anaconda.

Comment 9 Martin Ebourne 2010-03-19 23:32:03 UTC
Created attachment 401368 [details]
Attached traceback automatically from anaconda.

Comment 10 Chris Lumens 2010-03-25 20:41:26 UTC
*** Bug 577001 has been marked as a duplicate of this bug. ***

Comment 11 Eric Blake 2010-03-26 19:53:22 UTC
Created attachment 402930 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.