Bug 56857 - GRUB screen flicks at first cursor key scroll
Summary: GRUB screen flicks at first cursor key scroll
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-29 00:08 UTC by Hakon
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 10:33:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hakon 2001-11-29 00:08:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot computer - GRUB loads
2. Step away from highlighted option using the up/down keys on the 
keyboard - the screen flicks
3. Step away again - it doesn't flick from now

Actual Results:  The screen flicks

Expected Results:  It shouldn't flick, as it never does after second 
cursorkey step

Additional info:

In case GRUB can also be console/text, I will state that this occurs in 
graphical mode.

Comment 1 Jeremy Katz 2001-11-29 01:34:06 UTC
The flicker is due to a redraw to get rid of the countdown at the bottom of the
screen.

Comment 2 Hakon 2001-11-29 13:34:03 UTC
I see, but does it really have to flicker?

Comment 3 Hakon 2001-12-08 10:33:08 UTC
I see, but does the whole picture really have to flicker because of that?

Comment 4 Jeremy Katz 2002-01-02 20:09:44 UTC
Redraws in BIOS mode tend to flicker...  it's not like there's a lot of support
for doing graphics nicely this early in a PC's boot process :)


Note You need to log in before you can comment on or make changes to this bug.