Bug 56866 - checksetup.pl fails wit error no XML::Parser installed in Bugzilla-2.14-1
checksetup.pl fails wit error no XML::Parser installed in Bugzilla-2.14-1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
triage|leonardjo|closed|currentrelease
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-29 01:58 EST by Michael Hatchard
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 11:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hatchard 2001-11-29 01:58:24 EST
When running checksetup.pl from bugilla-2.14-1 I get the error I don't have
the XML parser. Running the perl -MCPAN -e'install "XML::Parser"' creates a
error can't locate object method "new" via package "HTTP::Request" at
/usr/lib/perl5/site_perl/5.6.0/HTTP/Request.pm at line 58. 


Redhat 7-1 (All know errata installed) Bugzilla-2.14-1

How Reproducible: Every Time


Steps to Reproduce:
1. Install mysql,bugzilla and all associated rpm I could find
2. Run checksetup.pl get error no XML::Parser
3. Run perl command get error for mcpan module

Actual Results:
Fails to run the perl command due to an error

Expected Results:
To run perl command and update the xml-parser

Additional Information:
Can't find perl-XML-Parser rpm
Comment 1 Tim Powers 2002-11-13 15:25:06 EST
You should be able to install the perl-XML-Parser package from Red Hat Linux 7.2
to satisfy the package not existing problem. As for the error that perl is
spitting out, I'll have to change the component to perl and the product to Red
Hat Linux.

Tim
Comment 2 Leonard den Ottolander 2004-04-22 11:59:31 EDT
Bugzilla is no longer shipped and perl-XML-Parser is now part of the
distribution.

Closing CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.