This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 568693 - Memory with Evolution
Memory with Evolution
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 06:42 EST by Daniel Rowe
Modified: 2010-07-07 08:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 05:50:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
valgrind report (4.61 MB, text/plain)
2010-02-26 20:39 EST, Daniel Rowe
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 620815 None None None Never

  None (edit)
Description Daniel Rowe 2010-02-26 06:42:17 EST
Description of problem:

evolution leaks memory. On my x86_64 Fedora 12 box I have found a few time now that all the memory have gone away cause the machine to swap.

What appears to happen is after evolution is exited it is not really exiting and leaves evolution processes running. These processes over 12 hours use all of my 8gigs and good part of the 6 gig of swap. Killing the process with kill frees all memory back to the system.  

Version-Release number of selected component (if applicable):

evolution-data-server-doc-2.28.2-1.fc12.noarch
evolution-help-2.28.2-1.fc12.noarch
evolution-data-server-2.28.2-1.fc12.x86_64
evolution-2.28.2-1.fc12.x86_64
evolution-data-server-devel-2.28.2-1.fc12.x86_64

How reproducible:

Seems to do it randomly, unable to trigger it. 

Steps to Reproduce:
1. Run evolution
2. Do normal email stuff i.e. read email and send email.
3. Quit evolution
4. Check to see if it has really quit, if not watch memory slowly leak away. 
  
Actual results:

Large memory leak.

Expected results:

No memory leak.

Additional info:

Let me know of any information I can gather to help fix this.
Comment 1 Milan Crha 2010-02-26 07:20:06 EST
Thanks for a bug report. What account types do you have setup in evolution? It's like IMAP, POP3, .... Could you install debug info packages for evolution and evolution-data-server and when you'll see that evolution is not quit after say 5 minutes it disappears after File->Quit, could you get its actual state, please? You can achieve that with these steps, for example:
a) close evolution and run on console: evolution --force-shutdown
b) run evolution on that console (maybe something useful will be shown there)
c) use it as you described above, and then quit it.
d) watch evolution console from b) whether something new appeared after c)
e) after those ~5 minutes, if evolution still running, run this command:
   $ ps -A | grep evo
   to get evolution process ID (used PID below)
   $ gdb --batch --ex "t a a bt" -pid=PID &>evo.bt

the evo.bt should contain actual state of it.

The other option is to run evolution in valgrind and see where it leaked the memory, but as it's too slow I would suggest to start with the above.

Thanks in advance.
Comment 2 Daniel Rowe 2010-02-26 08:29:58 EST
Using IMAP accounts with all mail stored on server.

Will install debug packages and try and catch it.
Comment 3 Daniel Rowe 2010-02-26 20:39:23 EST
Created attachment 396710 [details]
valgrind report

Looks like valgrind is reporting a leak.
Comment 4 Bojan Smojver 2010-06-03 02:08:04 EDT
I'm seeing unbelievably high memory usage with Evo in F-13, using evolution-exchange to connect to OWA. It is currently using 253 MB of RES memory, out of 1 GB available on the system.

With imap, on another system, I'm seeing almost 100 MB of RES being used.

Hmm... I'm also seeing memory leaks in krb5-auth-dialog and Xvnc with F-13. Maybe something all of these use is causing such high memory consumption. Not sure.
Comment 5 Bojan Smojver 2010-06-03 07:34:42 EDT
Up to 254 MB RES now. WOW!
Comment 6 Milan Crha 2010-06-07 05:50:05 EDT
Thanks for the update, David. Your valgrind log shows some leaks (those definitely lost), but even it's not nice to have them there, it's nothing significant. Even I agree it can grew in time.

> LEAK SUMMARY:
>    definitely lost: 30,276 bytes in 109 blocks
>    indirectly lost: 80,112 bytes in 2,486 blocks
>      possibly lost: 23,882,321 bytes in 284,665 blocks
>    still reachable: 1,675,501 bytes in 15,250 blocks
>         suppressed: 0 bytes in 0 blocks

I'm moving this upstream, as it's not a Fedora specific issue. Please see [1] for any further updates.

Bojan, if you are not using only IMAP, and you see this too, please try to get the valgrind log as well and update [1] with it, as maybe it's on a different place for you. Also, have a valgrind log for 2.30 would be really appreciated, because there is not planned any update to 2.28 and thre were quite large changes between 2.28 and 2.30 with respect of background architecture. Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=620815
Comment 7 Bojan Smojver 2010-06-22 05:52:19 EDT
This(In reply to comment #6)

> Bojan, if you are not using only IMAP, and you see this too, please try to get
> the valgrind log as well and update [1] with it, as maybe it's on a different
> place for you. Also, have a valgrind log for 2.30 would be really appreciated,
> because there is not planned any update to 2.28 and thre were quite large
> changes between 2.28 and 2.30 with respect of background architecture. Thanks
> in advance.
> 
> [1] https://bugzilla.gnome.org/show_bug.cgi?id=620815 

I'm using this with evolution-exchange. I didn't pay particular attention to any possible leaks on another machine where I use IMAP (more memory, more reboots).

I'm running evo under valgrind now, with --leak-check=yes --trace-children=yes. It is terribly slow, but hopefully I can get something out of it.
Comment 8 Bojan Smojver 2010-07-06 18:56:07 EDT
Any chance of applying some of the patches to Evo in F-13? Or rolling of 2.30.3?
Comment 9 Milan Crha 2010-07-07 04:08:43 EDT
There is planned 2.30.3 update for evolution packages, though the date wasn't set yet (I didn't notice any exact date myself). But the update will be done.
Comment 10 Bojan Smojver 2010-07-07 08:49:27 EDT
(In reply to comment #9)
> There is planned 2.30.3 update for evolution packages, though the date wasn't
> set yet (I didn't notice any exact date myself). But the update will be done.    

Wonderful, thank you.

Note You need to log in before you can comment on or make changes to this bug.