Bug 56874 - Not enough /dev/hda entries created by installer
Not enough /dev/hda entries created by installer
Status: CLOSED DUPLICATE of bug 43903
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-29 07:40 EST by Martin N Dunstan
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-29 07:40:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Martin N Dunstan 2001-11-29 07:40:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
I partitioned a large IDE disk into 17
partitions using DiskDruid with /tmp on
/dev/hda17. The installer only created
entries for hda1 to hda16 so it failed to
mount /tmp properly when it booted for the
first time. It ought to count the number of
partitions in the partition table and create
enough /dev entries to cope.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Partition your first IDE disk using
  DiskDruid to get at least 17 partions.
  Try having /tmp on /dev/hda17
2.Comlete the installation as normal
3.Watch what happens on reboot

Actual Results:  I forget the precise problem/error but
it related to the fact that /dev/hda17
did not exist so /tmp couldn't be mounted.
Instead the mount point was used as /tmp.

Expected Results:  The installer ought to create /dev entries
for every partition that it has been told
about (from DiskDruid or whatever).

Additional info:
Comment 1 Brent Fox 2001-12-03 20:34:20 EST

*** This bug has been marked as a duplicate of 43903 ***

Note You need to log in before you can comment on or make changes to this bug.